summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-extended')
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb4
-rw-r--r--meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb2
-rw-r--r--meta-openstack/recipes-extended/qpid/qpid_0.20.bb4
-rw-r--r--meta-openstack/recipes-extended/tempest/tempest_git.bb64
-rw-r--r--meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb6
5 files changed, 40 insertions, 40 deletions
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
index c6b3529..8bbbef1 100644
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
+++ b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
@@ -36,7 +36,7 @@ do_install_append() {
36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints 36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints
37} 37}
38 38
39inherit setuptools update-rc.d 39inherit setuptools3 update-rc.d
40 40
41PACKAGES += "${PN}-systemd" 41PACKAGES += "${PN}-systemd"
42 42
@@ -49,5 +49,5 @@ INITSCRIPT_PACKAGES = "${PN}"
49INITSCRIPT_NAME_${BPN} = "cloud-init" 49INITSCRIPT_NAME_${BPN} = "cloud-init"
50 50
51RDEPENDS_${PN} = "sysklogd \ 51RDEPENDS_${PN} = "sysklogd \
52 python \ 52 python3 \
53 " 53 "
diff --git a/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb b/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb
index 888bb09..9db4685 100644
--- a/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb
+++ b/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb
@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "3ca55a5aa11fbbd4e26cb4cdafc9658489c159acadceac60c89d4bfb5c
12 12
13S = "${WORKDIR}/qpid-${PV}/python" 13S = "${WORKDIR}/qpid-${PV}/python"
14 14
15inherit distutils 15inherit distutils3
diff --git a/meta-openstack/recipes-extended/qpid/qpid_0.20.bb b/meta-openstack/recipes-extended/qpid/qpid_0.20.bb
index b76f76d..933f5ef 100644
--- a/meta-openstack/recipes-extended/qpid/qpid_0.20.bb
+++ b/meta-openstack/recipes-extended/qpid/qpid_0.20.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qpid.apache.org/"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7ab4c208aa62d92d7a03cc8e0a89c12b" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=7ab4c208aa62d92d7a03cc8e0a89c12b"
5SECTION = "mq" 5SECTION = "mq"
6DEPENDS = "boost perl-native python util-linux cyrus-sasl" 6DEPENDS = "boost perl-native python3 util-linux cyrus-sasl"
7RDEPENDS_${PN} = "cyrus-sasl-bin" 7RDEPENDS_${PN} = "cyrus-sasl-bin"
8PR = "r0" 8PR = "r0"
9 9
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "31b80ba3c4773d288b4e6245e3b2048438386331d460f7a7b0794cbd20
17 17
18S = "${WORKDIR}/${PN}c-${PV}" 18S = "${WORKDIR}/${PN}c-${PV}"
19 19
20inherit autotools python-dir perlnative cpan-base update-rc.d pkgconfig 20inherit autotools python3-dir perlnative cpan-base update-rc.d pkgconfig
21 21
22# Env var which tells perl if it should use host (no) or target (yes) settings 22# Env var which tells perl if it should use host (no) or target (yes) settings
23export PERLCONFIGTARGET = "${@is_target(d)}" 23export PERLCONFIGTARGET = "${@is_target(d)}"
diff --git a/meta-openstack/recipes-extended/tempest/tempest_git.bb b/meta-openstack/recipes-extended/tempest/tempest_git.bb
index c7d1dd0..48a286c 100644
--- a/meta-openstack/recipes-extended/tempest/tempest_git.bb
+++ b/meta-openstack/recipes-extended/tempest/tempest_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7PR = "r0" 7PR = "r0"
8SRCNAME = "tempest" 8SRCNAME = "tempest"
9 9
10inherit setuptools identity hosts 10inherit setuptools3 identity hosts
11 11
12SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 12SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
13 file://tempest.conf \ 13 file://tempest.conf \
@@ -122,36 +122,36 @@ RDEPENDS_${PN} += " \
122 ${SRCNAME}-setup \ 122 ${SRCNAME}-setup \
123 ${SRCNAME}-setup-altdemo \ 123 ${SRCNAME}-setup-altdemo \
124 ${SRCNAME}-setup-admin \ 124 ${SRCNAME}-setup-admin \
125 python-mox \ 125 python3-mox \
126 python-mock \ 126 python3-mock \
127 python-hp3parclient \ 127 python3-hp3parclient \
128 python-oauth2 \ 128 python3-oauth2 \
129 python-testrepository \ 129 python3-testrepository \
130 python-fixtures \ 130 python3-fixtures \
131 python-keyring \ 131 python3-keyring \
132 python-glanceclient \ 132 python3-glanceclient \
133 python-keystoneclient \ 133 python3-keystoneclient \
134 python-swiftclient \ 134 python3-swiftclient \
135 python-novaclient \ 135 python3-novaclient \
136 python-cinderclient \ 136 python3-cinderclient \
137 python-heatclient \ 137 python3-heatclient \
138 python-pbr \ 138 python3-pbr \
139 python-anyjson \ 139 python3-anyjson \
140 python-nose \ 140 python3-nose \
141 python-httplib2 \ 141 python3-httplib2 \
142 python-jsonschema \ 142 python3-jsonschema \
143 python-testtools \ 143 python3-testtools \
144 python-lxml \ 144 python3-lxml \
145 python-boto \ 145 python3-boto \
146 python-paramiko \ 146 python3-paramiko \
147 python-netaddr \ 147 python3-netaddr \
148 python-testresources \ 148 python3-testresources \
149 python-oslo.config \ 149 python3-oslo.config \
150 python-eventlet \ 150 python3-eventlet \
151 python-six \ 151 python3-six \
152 python-iso8601 \ 152 python3-iso8601 \
153 python-mimeparse \ 153 python3-mimeparse \
154 python-flake8 \ 154 python3-flake8 \
155 python-tox \ 155 python3-tox \
156 " 156 "
157 157
diff --git a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
index f0c535f..bf6b30f 100644
--- a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
+++ b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
@@ -14,15 +14,15 @@ SRCREV="af44211739136e22471a2897383f34586284bf86"
14PV="2.0.14+git${SRCPV}" 14PV="2.0.14+git${SRCPV}"
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit setuptools pkgconfig 17inherit setuptools3 pkgconfig
18 18
19# prevent host contamination and remove local search paths 19# prevent host contamination and remove local search paths
20export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include" 20export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include"
21 21
22DEPENDS += " \ 22DEPENDS += " \
23 e2fsprogs \ 23 e2fsprogs \
24 python-pip \ 24 python3-pip \
25 python-six \ 25 python3-six \
26 yajl \ 26 yajl \
27 " 27 "
28 28