summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb')
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
index 01ee924..c6b3529 100644
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
+++ b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
@@ -28,19 +28,15 @@ do_install_prepend() {
28 28
29do_install_append() { 29do_install_append() {
30 install -m 0755 ${WORKDIR}/cloud.cfg ${D}${sysconfdir}/cloud/cloud.cfg 30 install -m 0755 ${WORKDIR}/cloud.cfg ${D}${sysconfdir}/cloud/cloud.cfg
31 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then 31
32 sed -e "s:%MANAGE_HOSTS%:${MANAGE_HOSTS}:g" -i ${D}${sysconfdir}/cloud/cloud.cfg 32 sed -e "s:%MANAGE_HOSTS%:${MANAGE_HOSTS}:g" -i ${D}${sysconfdir}/cloud/cloud.cfg
33 sed -e "s:%HOSTNAME%:${HOSTNAME}:g" -i ${D}${sysconfdir}/cloud/cloud.cfg 33 sed -e "s:%HOSTNAME%:${HOSTNAME}:g" -i ${D}${sysconfdir}/cloud/cloud.cfg
34 fi 34
35 ln -s ${libdir}/${BPN}/uncloud-init ${D}${sysconfdir}/cloud/uncloud-init 35 ln -s ${libdir}/${BPN}/uncloud-init ${D}${sysconfdir}/cloud/uncloud-init
36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints 36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints
37} 37}
38 38
39inherit setuptools update-rc.d openstackchef 39inherit setuptools update-rc.d
40
41CHEF_SERVICES_CONF_FILES := " \
42 ${sysconfdir}/cloud/cloud.cfg \
43 "
44 40
45PACKAGES += "${PN}-systemd" 41PACKAGES += "${PN}-systemd"
46 42