summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/erubis_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/ohai_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/rest-client_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb2
13 files changed, 15 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
index 1ade265..993e292 100644
--- a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
26 26
27inherit ruby 27inherit ruby
28 28
29RDEPENDS_${PN} += " \ 29RDEPENDS:${PN} += " \
30 mixlib-log \ 30 mixlib-log \
31 json \ 31 json \
32 hashie \ 32 hashie \
diff --git a/meta-openstack/recipes-devtools/ruby/erubis_git.bb b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
index 08e0f28..540231a 100644
--- a/meta-openstack/recipes-devtools/ruby/erubis_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
@@ -21,7 +21,7 @@ SRC_URI = " \
21 21
22inherit ruby 22inherit ruby
23 23
24do_patch_append() { 24do_patch:append() {
25 bb.build.exec_func('do_fixup_gemspec', d) 25 bb.build.exec_func('do_fixup_gemspec', d)
26} 26}
27 27
diff --git a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
index 768bc21..71b0533 100644
--- a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
+++ b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
@@ -7,13 +7,13 @@ SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;tag=v${PV}"
7 7
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10RDEPENDS_${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby" 10RDEPENDS:${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
11 11
12inherit ruby 12inherit ruby
13 13
14do_install_append() { 14do_install:append() {
15 install -d ${D}/etc/fluent/ 15 install -d ${D}/etc/fluent/
16 install ${S}/fluent.conf ${D}/etc/fluent/fluent.conf 16 install ${S}/fluent.conf ${D}/etc/fluent/fluent.conf
17} 17}
18 18
19INSANE_SKIP_${PN} = "installed-vs-shipped" 19INSANE_SKIP:${PN} = "installed-vs-shipped"
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
index db52ebd..6bf809e 100644
--- a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
@@ -16,7 +16,7 @@ DEPENDS = "git"
16inherit ruby 16inherit ruby
17 17
18# Download the submodules 18# Download the submodules
19do_configure_prepend() { 19do_configure:prepend() {
20 cd ${WORKDIR}/git 20 cd ${WORKDIR}/git
21 git submodule update --init --recursive 21 git submodule update --init --recursive
22} 22}
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
index b380e01..c34b74b 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
@@ -22,7 +22,7 @@ SRC_URI = " \
22 22
23inherit ruby 23inherit ruby
24 24
25RDEPENDS_${PN} += " \ 25RDEPENDS:${PN} += " \
26 mixlib-log \ 26 mixlib-log \
27 " 27 "
28 28
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
index b823a03..21fe406 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
26 26
27inherit ruby 27inherit ruby
28 28
29RDEPENDS_${PN} += " \ 29RDEPENDS:${PN} += " \
30 net-ssh \ 30 net-ssh \
31 " 31 "
32 32
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
index 7da0566..965eae1 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
26 26
27inherit ruby 27inherit ruby
28 28
29RDEPENDS_${PN} += " \ 29RDEPENDS:${PN} += " \
30 net-ssh \ 30 net-ssh \
31 net-ssh-gateway \ 31 net-ssh-gateway \
32 " 32 "
diff --git a/meta-openstack/recipes-devtools/ruby/ohai_git.bb b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
index 5820c44..ee5c735 100644
--- a/meta-openstack/recipes-devtools/ruby/ohai_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
@@ -25,7 +25,7 @@ SRC_URI = " \
25 25
26inherit ruby 26inherit ruby
27 27
28RDEPENDS_${PN} += " \ 28RDEPENDS:${PN} += " \
29 mime-types \ 29 mime-types \
30 ipaddress \ 30 ipaddress \
31 mixlib-cli \ 31 mixlib-cli \
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
index a4eb63c..3480cdc 100644
--- a/meta-openstack/recipes-devtools/ruby/pry_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -26,7 +26,7 @@ inherit ruby
26 26
27RUBY_COMPILE_FLAGS = "" 27RUBY_COMPILE_FLAGS = ""
28 28
29RDEPENDS_${PN} += " \ 29RDEPENDS:${PN} += " \
30 coderay \ 30 coderay \
31 method-source \ 31 method-source \
32 slop \ 32 slop \
diff --git a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
index 923e9f2..0837a3b 100644
--- a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
@@ -23,7 +23,7 @@ SRC_URI = " \
23 23
24inherit ruby 24inherit ruby
25 25
26RDEPENDS_${PN} += " \ 26RDEPENDS:${PN} += " \
27 mime-types \ 27 mime-types \
28 " 28 "
29 29
diff --git a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
index 1ed8f9e..516a72e 100644
--- a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
@@ -8,6 +8,6 @@ SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;tag=v2
8 8
9S = '${WORKDIR}/git' 9S = '${WORKDIR}/git'
10 10
11RDEPENDS_${PN} = "sigdump" 11RDEPENDS:${PN} = "sigdump"
12 12
13inherit ruby 13inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb b/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
index 20a1f5b..53a2f8a 100644
--- a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
@@ -8,6 +8,6 @@ SRC_URI = "git://github.com/nurse/strptime.git;protocol=https;tag=v0.2.3"
8 8
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10 10
11RDEPENDS_${PN} = "bash" 11RDEPENDS:${PN} = "bash"
12 12
13inherit ruby 13inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
index 2ea1f2d..2f7bc66 100644
--- a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
@@ -8,6 +8,6 @@ SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;tag=v2.0.1"
8 8
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10 10
11RDEPENDS_${PN} = "concurrent-ruby" 11RDEPENDS:${PN} = "concurrent-ruby"
12 12
13inherit ruby 13inherit ruby