summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb51
1 files changed, 0 insertions, 51 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
deleted file mode 100644
index 5e5e43e..0000000
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1DESCRIPTION = "CLI and python client library for OpenStack Ceilometer"
2HOMEPAGE = "https://launchpad.net/ceilometer"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python-pbr \
19 python-iso8601 \
20 python-keystoneauth1 \
21 python-oslo.i18n \
22 python-oslo.serialization \
23 python-oslo.utils \
24 python-prettytable \
25 python-requests \
26 python-six \
27 python-stevedore \
28 bash \
29 "
30
31SRC_URI = "\
32 git://github.com/openstack/python-ceilometerclient.git;branch=stable/pike \
33 "
34
35PV = "2.9.1"
36SRCREV = "4ee321feeef39fa2a297ad8e58e931b8a03d8f14"
37S = "${WORKDIR}/git"
38
39inherit setuptools3 rmargparse
40
41
42PACKAGECONFIG ?= "bash-completion"
43PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
44
45do_install_append() {
46 install -d ${D}/${sysconfdir}/bash_completion.d
47 install -m 664 ${S}/tools/ceilometer.bash_completion ${D}/${sysconfdir}/bash_completion.d
48}
49
50PACKAGES =+ "${BPN}-bash-completion"
51FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"