summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-hgtools.inc13
-rw-r--r--meta-openstack/recipes-devtools/python/python3-hgtools_6.3.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-hgtools_8.2.0.bb16
3 files changed, 16 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-hgtools.inc b/meta-openstack/recipes-devtools/python/python-hgtools.inc
deleted file mode 100644
index 561df3d..0000000
--- a/meta-openstack/recipes-devtools/python/python-hgtools.inc
+++ /dev/null
@@ -1,13 +0,0 @@
1DESCRIPTION = "Classes and setuptools plugin for Mercurial repositories"
2HOMEPAGE = "https://pypi.python.org/pypi/hgtools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a428d7abf1504d4dfeb4cbde155ba484"
6
7PYPI_PACKAGE_EXT = "zip"
8
9SRC_URI[md5sum] = "584d74b81b1efae3604c53086d1a3acb"
10SRC_URI[sha256sum] = "1d0ef6ceaba1673e6923b17d7f09c5ae2f4394d16ef80562812987a27e7836ff"
11
12inherit pypi
13
diff --git a/meta-openstack/recipes-devtools/python/python3-hgtools_6.3.bb b/meta-openstack/recipes-devtools/python/python3-hgtools_6.3.bb
deleted file mode 100644
index 51a488f..0000000
--- a/meta-openstack/recipes-devtools/python/python3-hgtools_6.3.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-hgtools.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-hgtools_8.2.0.bb b/meta-openstack/recipes-devtools/python/python3-hgtools_8.2.0.bb
new file mode 100644
index 0000000..cfaf034
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-hgtools_8.2.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Classes and setuptools plugin for Mercurial repositories"
2HOMEPAGE = "https://pypi.python.org/pypi/hgtools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7SRC_URI[md5sum] = "200c967071c63efeb869470d24f250e3"
8SRC_URI[sha256sum] = "5f30e3e7729f67e414b63ae91697743bb2ec72f3cac0c514d16fd3c21bd25300"
9
10DEPENDS += " \
11 python3-setuptools-scm-native \
12 python3-toml-native \
13"
14
15inherit setuptools3 pypi
16