summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.config_8.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.config_8.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.config_8.4.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.config_8.4.0.bb b/meta-openstack/recipes-devtools/python/python3-oslo.config_8.4.0.bb
new file mode 100644
index 0000000..3b89b51
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.config_8.4.0.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "API supporting parsing command line arguments and .ini style configuration files."
2HOMEPAGE = "https://pypi.python.org/pypi/oslo.config/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6
7SRC_URI[sha256sum] = "537d62c581de2227aebfc4c71ee6fb455b853be920e0b30b65ebbe8d8128725c"
8
9inherit setuptools3 pypi
10
11DEPENDS += " \
12 python3-pbr \
13 python3-pbr-native \
14 python3-pip \
15 "
16
17RDEPENDS_${PN} += " \
18 python3-requests \
19 python3-netaddr \
20 python3-stevedore \
21 python3-debtcollector \
22 python3-oslo.i18n \
23 python3-rfc3986 \
24 python3-pyyaml \
25 "
26