summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-os-brick_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-os-brick_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-os-brick_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-os-brick_git.bb b/meta-openstack/recipes-devtools/python/python3-os-brick_git.bb
new file mode 100644
index 0000000..4fc01f6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-os-brick_git.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "OpenStack Cinder brick library for managing local volume attaches"
2HOMEPAGE = "https://github.com/openstack/os-brick"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-brick.git;branch=stable/victoria \
9 "
10SRCREV = "f0cf77672fed70f20896c23015cb50341f311f38"
11
12PV = "4.0.1+git${SRCPV}"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17FILES_${PN} += "${datadir}/etc/*"
18
19DEPENDS += " \
20 python3-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python3-pbr-native \
26 "
27
28RDEPENDS_${PN} += " \
29 python3-pbr \
30 python3-babel \
31 python3-eventlet \
32 python3-oslo.concurrency \
33 python3-oslo.log \
34 python3-oslo.serialization \
35 python3-oslo.i18n \
36 python3-oslo.privsep \
37 python3-oslo.service \
38 python3-oslo.utils \
39 python3-requests \
40 python3-retrying \
41 python3-six \
42 python3-os-win \