summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb b/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb
new file mode 100644
index 0000000..9cdc9a2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb
@@ -0,0 +1,26 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "Openstack style output for nosetests"
5HOMEPAGE = "https://github.com/jkoelker/openstack-nose"
6SECTION = "devel/python"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
9
10PYPI_PACKAGE = "openstack.nose_plugin"
11
12SRC_URI[md5sum] = "0c6547f413db8c66921b110f78132aac"
13SRC_URI[sha256sum] = "a28d44dc23de8164d7893da7020404c73c4325b46d5507911f0257c15f613b4f"
14
15inherit setuptools3 pypi
16
17DEPENDS += " \
18 python3-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 python3-nose \
23 python3-colorama \
24 python3-termcolor \
25 "
26