summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-mox3_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-mox3_1.1.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-mox3_1.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-mox3_1.1.0.bb b/meta-openstack/recipes-devtools/python/python3-mox3_1.1.0.bb
new file mode 100644
index 0000000..9608077
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-mox3_1.1.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "mox3: mock object framework for Python"
2HOMEPAGE = "https://pypi.python.org/pypi/mox3"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "0eff74d3a85ec4d4dc6acf7f524ca816"
8SRC_URI[sha256sum] = "8a526b7b9b6341f541a9aef3e08c93fd84a5373fe89d4cc51dd571f085b2363c"
9
10inherit setuptools3 pypi
11
12DEPENDS += "\
13 python3-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python3-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python3-pbr \
23 python3-fixtures \
24"