summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-keyring_22.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-keyring_22.0.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keyring_22.0.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-keyring_22.0.1.bb b/meta-openstack/recipes-devtools/python/python3-keyring_22.0.1.bb
new file mode 100644
index 0000000..1eba7f6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-keyring_22.0.1.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Store and access your passwords safely"
2HOMEPAGE = "https://pypi.python.org/pypi/keyring/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7SRC_URI[md5sum] = "88e1607f9f40b82ab9e28529eec3edbc"
8SRC_URI[sha256sum] = "9acb3e1452edbb7544822b12fd25459078769e560fa51f418b6d00afaa6178df"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-hgtools \
14 python3-setuptools-scm-native \
15 python3-toml-native \
16"
17
18RDEPENDS_${PN} = " \
19 python3-logging \
20 python3-importlib-metadata \
21"