summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-keyring_21.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-keyring_21.5.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keyring_21.5.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-keyring_21.5.0.bb b/meta-openstack/recipes-devtools/python/python3-keyring_21.5.0.bb
new file mode 100644
index 0000000..59e6dbf
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-keyring_21.5.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Store and access your passwords safely"
2HOMEPAGE = "https://pypi.python.org/pypi/keyring/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7SRC_URI[md5sum] = "1609e4804bfc08ca0adf43f9d9c90de6"
8SRC_URI[sha256sum] = "207bd66f2a9881c835dad653da04e196c678bf104f8252141d2d3c4f31051579"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-hgtools \
14 python3-setuptools-scm-native \
15 python3-toml-native \
16"
17
18RDEPENDS_${PN} = " \
19 python3-logging \
20 python3-importlib-metadata \
21 python3-typing \
22"