summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb b/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb
new file mode 100644
index 0000000..569a546
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Store and access your passwords safely"
2HOMEPAGE = "https://pypi.python.org/pypi/keyring/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7SRC_URI[md5sum] = "c9691de646eced3b15e888e5b410d6a1"
8SRC_URI[sha256sum] = "9aeadd006a852b78f4b4ef7c7556c2774d2432bbef8ee538a3e9089ac8b11466"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-hgtools \
14 python3-setuptools-scm-native \
15 python3-toml-native \
16"
17
18RDEPENDS_${PN} = " \
19 python3-logging \
20 python3-importlib-metadata \
21"