summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-httpretty_1.0.5.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-httpretty_1.0.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.5.bb b/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.5.bb
new file mode 100644
index 0000000..4b732ca
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.5.bb
@@ -0,0 +1,24 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "HTTP client mock for Python"
5HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
6SECTION = "devel/python"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d87f7868a62b8d598eab40164594d21b"
9
10SRC_URI[md5sum] = "6d71a2387997ae8523dcc7ada51cb46a"
11SRC_URI[sha256sum] = "e53c927c4d3d781a0761727f1edfad64abef94e828718e12b672a678a8b3e0b5"
12
13inherit setuptools3 pypi
14
15DEPENDS += " \
16 ${PYTHON_PN}-pip \
17 "
18
19RDEPENDS_${PN} = " \
20 ${PYTHON_PN}-crypt \
21 ${PYTHON_PN}-logging \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-core \
24"