summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-glance-store_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-glance-store_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-glance-store_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-glance-store_git.bb b/meta-openstack/recipes-devtools/python/python3-glance-store_git.bb
new file mode 100644
index 0000000..5079958
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-glance-store_git.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Glance stores library"
2HOMEPAGE = "https://github.com/openstack/glance_store"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://git.openstack.org/openstack/glance_store.git;branch=stable/pike \
9 "
10
11PV="0.22.0+git${SRCPV}"
12SRCREV="49c915f498fc8d91c98fcf4e07ceecdcf167fc5a"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python3-pip \
19 python3-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python3-pbr-native \
25 "
26
27RDEPENDS_${PN} += " \
28 bash \
29 python3-oslo.config \
30 python3-oslo.i18n \
31 python3-oslo.serialization \
32 python3-oslo.utils \
33 python3-oslo.concurrency \
34 python3-stevedore \
35 python3-eventlet \
36 python3-six \
37 python3-jsonschema \
38 python3-keystoneauth1 \
39 python3-keystoneclient \
40 python3-requests \
41 python3-monotonic \
42 python3-dnspython \
43 "