summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-futurist_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-futurist_2.3.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-futurist_2.3.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-futurist_2.3.0.bb b/meta-openstack/recipes-devtools/python/python3-futurist_2.3.0.bb
new file mode 100644
index 0000000..2e63d90
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-futurist_2.3.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Useful additions to futures, from the future"
2HOMEPAGE = "https://pypi.python.org/pypi/futurist"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "4d642f5825a516d676356094179c6d27"
8SRC_URI[sha256sum] = "174ea146adf303d7e5d7d6d34e3a01f4abf0382b03a6f9309bac2e2d54ffbed6"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-pip \
14 python3-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python3-pbr \
19 python3-six \
20 python3-monotonic \
21 python3-contextlib2 \
22 python3-prettytable \
23 python3-multiprocessing \
24 "
25