summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb b/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb
new file mode 100644
index 0000000..4e6c2d2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "A Django authentication backend for use with the OpenStack Keystone backend."
2HOMEPAGE = "http://django_openstack_auth.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PYPI_PACKAGE = "django_openstack_auth"
8
9SRC_URI[sha256sum] = "9a441fdea3f662fd727f020f479b3e89c96a2cc442c49539634c996a967dd378"
10
11inherit setuptools3 pypi
12
13DEPENDS += " \
14 python3-pip \
15 python3-pbr-native \
16 "
17
18RDEPENDS_${PN} += " \
19 python3-pbr \
20 python3-django \
21 python3-oslo.config \
22 python3-oslo.policy \
23 python3-keystoneclient \
24 python3-keystoneauth1 \
25 python3-six \
26 "