summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-django-compressor_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-django-compressor_2.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-django-compressor_2.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-django-compressor_2.1.bb b/meta-openstack/recipes-devtools/python/python3-django-compressor_2.1.bb
new file mode 100644
index 0000000..40a0133
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-django-compressor_2.1.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Compresses linked and inline JavaScript or CSS into single cached files."
2HOMEPAGE = "http://django-compressor.readthedocs.org/en/latest/"
3SECTION = "devel/python"
4LICENSE = "MIT & BSD-3-Clause & BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=021598d037fd39ab02e53249e1fe4b6f"
6
7PYPI_PACKAGE = "django_compressor"
8
9SRC_URI[md5sum] = "21ecfe4e8615eae64f7068a5599df9af"
10SRC_URI[sha256sum] = "ae0051bc0c7a0660c93434e68d617553fccdd573293dfd15aa33f78d2b4954ef"
11
12inherit setuptools3 pypi
13
14RDEPENDS_${PN} += " \
15 python3-django-appconf \
16 python3-rcssmin \
17 python3-rjsmin \
18 "
19
20do_install_append() {
21 # Ensure permisive perms are granted
22 find -L "${D}${PYTHON_SITEPACKAGES_DIR}/compressor" -type f -exec chmod 644 {} \;
23 find -L "${D}${PYTHON_SITEPACKAGES_DIR}/compressor" -type d -exec chmod 755 {} \;
24}
25
26
27CLEANBROKEN = "1"