summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-designateclient_4.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-designateclient_4.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-designateclient_4.2.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-designateclient_4.2.0.bb b/meta-openstack/recipes-devtools/python/python3-designateclient_4.2.0.bb
new file mode 100644
index 0000000..153429b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-designateclient_4.2.0.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Python bindings to the Designate API"
2HOMEPAGE = "https://github.com/openstack/python-designateclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 python3-pip \
9 python3-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python3-pbr-native \
15 "
16SRC_URI[md5sum] = "51e6aaf70e253c999824c7bc29009f5e"
17SRC_URI[sha256sum] = "cf0e76540530491a6100164c514e1c60b55efa25c8db4c18f4902c988d7c1080"
18
19RDEPENDS_${PN} += " \
20 python3-cliff \
21 python3-jsonschema \
22 python3-osc-lib \
23 python3-oslo.utils \
24 python3-pbr \
25 python3-keystoneauth1 \
26 python3-requests \
27 python3-six \
28 python3-stevedore \
29 python3-debtcollector \
30 "
31
32PYPI_PACKAGE = "python-designateclient"
33
34inherit setuptools3 pypi