summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb b/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb
new file mode 100644
index 0000000..4c6bf70
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A collection of Python deprecation patterns and strategies that help you collect your technical debt in a non-destructive manner."
2HOMEPAGE = "http://docs.openstack.org/developer/debtcollector/"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7SRC_URI[md5sum] = "6ac3af37693e0f517e51593d9ea33f23"
8SRC_URI[sha256sum] = "787981f4d235841bf6eb0467e23057fb1ac7ee24047c32028a8498b9128b6829"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 ${PYTHON_PN}-pip \
14 ${PYTHON_PN}-pbr \
15 "
16
17# Satisfy setup.py 'setup_requires'
18DEPENDS += " \
19 ${PYTHON_PN}-pbr-native \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 ${PYTHON_PN}-pbr \
25 ${PYTHON_PN}-wrapt \
26 ${PYTHON_PN}-six \
27 "