summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb b/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb
new file mode 100644
index 0000000..770acdc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Library for validation of digital signatures."
2HOMEPAGE = "https://github.com/openstack/cursive"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7inherit setuptools3 pypi
8
9SRC_URI[sha256sum] = "fbdc2b088bf0b9a69b1897d726e6027e8fba8f21f0a881344f70e7a407d9abda"
10
11DEPENDS += " \
12 python3-pbr \
13 "
14
15# Satisfy setup.py 'setup_requires'
16DEPENDS += " \
17 python3-pbr-native \
18 "
19
20RDEPENDS_${PN} += " \
21 python3-pbr \
22 python3-lxml \
23 python3-cryptography \
24 python3-netifaces \
25 python3-six \
26 python3-oslo.serialization \
27 python3-oslo.utils \
28 python3-oslo.i18n \
29 python3-oslo.log \
30 python3-castellan \
31 "