summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-cliff_3.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-cliff_3.6.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-cliff_3.6.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-cliff_3.6.0.bb b/meta-openstack/recipes-devtools/python/python3-cliff_3.6.0.bb
new file mode 100644
index 0000000..29d38e0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-cliff_3.6.0.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Command Line Interface Formulation Framework"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "8dbf43ad5486186eb80e985ddb38fdec"
8SRC_URI[sha256sum] = "a3f4fa67eeafbcfa7cf9fe4b1755d410876528e1d0d115740db00b50a1250272"
9
10inherit setuptools3 pypi
11
12DEPENDS += "\
13 ${PYTHON_PN}-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 ${PYTHON_PN}-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-cmd2 \
23 ${PYTHON_PN}-pbr \
24 ${PYTHON_PN}-pyparsing \
25 ${PYTHON_PN}-prettytable \
26 ${PYTHON_PN}-six \
27 ${PYTHON_PN}-stevedore \
28 ${PYTHON_PN}-pyyaml \
29"
30
31CLEANBROKEN = "1"