summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb b/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb
new file mode 100644
index 0000000..062d375
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Generic Key Manager interface for OpenStack"
2HOMEPAGE = "https://github.com/openstack/castellan"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[sha256sum] = "53d39a4ae93c48d26f904f36ae2f3dedde6ad40d34b5f031c23055fff2a1d7f6"
8
9inherit setuptools3 pypi
10
11DEPENDS += " \
12 python3-pip \
13 python3-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python3-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python3-pbr \
23 python3-babel \
24 python3-cryptography \
25 python3-barbicanclient \
26 python3-oslo.config \
27 python3-oslo.context \
28 python3-oslo.i18n \
29 python3-oslo.log \
30 python3-oslo.utils \
31 python3-keystoneauth1 \
32 bash \
33 "