summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb34
1 files changed, 31 insertions, 3 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb b/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb
index 4b85cd5..b5d3e77 100644
--- a/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb
+++ b/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb
@@ -1,5 +1,33 @@
1require python-avahi.inc 1RDEPENDS_${PN} += "python3-core python3-dbus"
2SUMMARY = "Python bindings for the avahi zeroconf client"
3HOMEPAGE = "https://github.com/lathiat/avahi"
4SECTION = "devel/python"
2 5
3inherit python3-dir 6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
4 8
5RDEPENDS_${PN} += "python3-core python3-dbus" 9SRC_URI = "https://github.com/lathiat/avahi/releases/download/v${PV}/avahi-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "22b5e705d3eabb31d26f2e1e7b074013"
12SRC_URI[sha256sum] = "d54991185d514a0aba54ebeb408d7575b60f5818a772e28fa0e18b98bc1db454"
13
14S = "${WORKDIR}/avahi-${PV}"
15
16inherit python3native python3-dir
17
18# we only need the python bindings
19do_install () {
20 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/avahi
21
22 sed -i'' -e "s,@PYTHON\@,${bindir}/${PYTHON_PN},g" \
23 ${S}/avahi-python/avahi/__init__.py \
24 ${S}/avahi-python/avahi-bookmarks.in
25
26 install -m 0775 ${S}/avahi-python/avahi/__init__.py \
27 ${D}${PYTHON_SITEPACKAGES_DIR}/avahi/__init__.py
28
29 install -m 0775 ${S}/avahi-python/avahi-bookmarks.in \
30 ${D}${PYTHON_SITEPACKAGES_DIR}/avahi/avahi-bookmarks
31}
32
33FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/avahi"