summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-automaton_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-automaton_2.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-automaton_2.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-automaton_2.2.0.bb b/meta-openstack/recipes-devtools/python/python3-automaton_2.2.0.bb
new file mode 100644
index 0000000..7278dcc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-automaton_2.2.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Friendly state machines for python"
2HOMEPAGE = "https://pypi.python.org/pypi/automaton"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7SRC_URI[md5sum] = "00a1c07d012dfa228ce003d7527e4a7d"
8SRC_URI[sha256sum] = "88144e0ec07c40edcb70a547ea74ca5718994e7a0694b6c4cb6679e57eb26095"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-pip \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python3-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python3-pbr \
23 python3-six \
24 python3-debtcollector \
25 python3-prettytable \
26 "
27