summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-tox.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-tox.inc')
-rw-r--r--meta-openstack/recipes-devtools/python/python-tox.inc29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-tox.inc b/meta-openstack/recipes-devtools/python/python-tox.inc
new file mode 100644
index 0000000..66b1355
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-tox.inc
@@ -0,0 +1,29 @@
1DESCRIPTION = "virtualenv-based automation of test activities"
2HOMEPAGE = "http://tox.testrun.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f24505dfbdd8c22c61de6383f2e74bf9"
6
7inherit pypi
8
9DEPENDS += " \
10 ${PYTHON_PN}-pip \
11 "
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-virtualenv \
15 ${PYTHON_PN}-py \
16 ${PYTHON_PN}-pytest \
17 "
18
19do_install_append() {
20
21 install -d ${D}/${sysconfdir}/${SRCNAME}
22 cp ${S}/tox.ini ${D}/${sysconfdir}/${SRCNAME}
23 cp ${S}/setup.py ${D}/${sysconfdir}/${SRCNAME}
24 cp ${S}/README.md ${D}/${sysconfdir}/${SRCNAME}
25
26 ln -s ${PYTHON_SITEPACKAGES_DIR}/tox ${D}/${sysconfdir}/${SRCNAME}/tox
27}
28
29FILES_${PN} += "${sysconfdir}/${SRCNAME}/*"