summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-rally_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-rally_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-rally_git.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-rally_git.bb b/meta-openstack/recipes-devtools/python/python-rally_git.bb
index ef86418..063a2b9 100644
--- a/meta-openstack/recipes-devtools/python/python-rally_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-rally_git.bb
@@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
26 26
27inherit setuptools3 update-rc.d hosts identity default_configs 27inherit setuptools3 update-rc.d hosts identity default_configs
28 28
29do_install_append() { 29do_install:append() {
30 RALLY_CONF_DIR=${D}${sysconfdir}/${SRCNAME} 30 RALLY_CONF_DIR=${D}${sysconfdir}/${SRCNAME}
31 RALLY_PYTHON_SITEPACKAGES_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME} 31 RALLY_PYTHON_SITEPACKAGES_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}
32 32
@@ -62,7 +62,7 @@ do_install_append() {
62 cp -r ${S}/tools ${RALLY_CONF_DIR} 62 cp -r ${S}/tools ${RALLY_CONF_DIR}
63} 63}
64 64
65pkg_postinst_${SRCNAME}-setup () { 65pkg_postinst:${SRCNAME}-setup () {
66 if [ -z "$D" ]; then 66 if [ -z "$D" ]; then
67 # This is to make sure postgres is configured and running 67 # This is to make sure postgres is configured and running
68 if ! pidof postmaster > /dev/null; then 68 if ! pidof postmaster > /dev/null; then
@@ -80,18 +80,18 @@ pkg_postinst_${SRCNAME}-setup () {
80} 80}
81 81
82PACKAGES += "${SRCNAME}-tests ${SRCNAME}-api ${SRCNAME} ${SRCNAME}-setup" 82PACKAGES += "${SRCNAME}-tests ${SRCNAME}-api ${SRCNAME} ${SRCNAME}-setup"
83ALLOW_EMPTY_${SRCNAME}-setup = "1" 83ALLOW_EMPTY:${SRCNAME}-setup = "1"
84 84
85FILES_${PN} = "${libdir}/*" 85FILES:${PN} = "${libdir}/*"
86 86
87FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh \ 87FILES:${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh \
88 " 88 "
89 89
90FILES_${SRCNAME} = "${bindir}/* \ 90FILES:${SRCNAME} = "${bindir}/* \
91 ${sysconfdir}/${SRCNAME}/* \ 91 ${sysconfdir}/${SRCNAME}/* \
92 " 92 "
93 93
94FILES_${SRCNAME}-api = "${bindir}/rally-api \ 94FILES:${SRCNAME}-api = "${bindir}/rally-api \
95 ${sysconfdir}/init.d/rally-api \ 95 ${sysconfdir}/init.d/rally-api \
96 " 96 "
97 97
@@ -105,7 +105,7 @@ DEPENDS += " \
105 python-pbr-native \ 105 python-pbr-native \
106 " 106 "
107 107
108RDEPENDS_${PN} += " python-babel \ 108RDEPENDS:${PN} += " python-babel \
109 python-decorator \ 109 python-decorator \
110 python-fixtures \ 110 python-fixtures \
111 python-iso8601 \ 111 python-iso8601 \
@@ -131,7 +131,7 @@ RDEPENDS_${PN} += " python-babel \
131 python-wsme \ 131 python-wsme \
132 " 132 "
133 133
134RDEPENDS_${SRCNAME}-tests = "${PN} \ 134RDEPENDS:${SRCNAME}-tests = "${PN} \
135 python-coverage \ 135 python-coverage \
136 python-mock \ 136 python-mock \
137 python-testrepository \ 137 python-testrepository \
@@ -139,14 +139,14 @@ RDEPENDS_${SRCNAME}-tests = "${PN} \
139 python-oslotest \ 139 python-oslotest \
140 " 140 "
141 141
142RDEPENDS_${SRCNAME} = "${PN} \ 142RDEPENDS:${SRCNAME} = "${PN} \
143 postgresql \ 143 postgresql \
144 postgresql-client \ 144 postgresql-client \
145 " 145 "
146 146
147RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}" 147RDEPENDS:${SRCNAME}-setup = "postgresql sudo ${SRCNAME}"
148RDEPENDS_${SRCNAME}-api = "${SRCNAME}" 148RDEPENDS:${SRCNAME}-api = "${SRCNAME}"
149 149
150INITSCRIPT_PACKAGES = "${SRCNAME}-api" 150INITSCRIPT_PACKAGES = "${SRCNAME}-api"
151INITSCRIPT_NAME_${SRCNAME}-api = "${SRCNAME}-api" 151INITSCRIPT_NAME:${SRCNAME}-api = "${SRCNAME}-api"
152INITSCRIPT_PARAMS_${SRCNAME}-api = "${OS_DEFAULT_INITSCRIPT_PARAMS}" 152INITSCRIPT_PARAMS:${SRCNAME}-api = "${OS_DEFAULT_INITSCRIPT_PARAMS}"