summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-nova_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-nova_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb86
1 files changed, 43 insertions, 43 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 8c643bd..77e7b82 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -11,7 +11,7 @@ DEPENDS = " \
11 11
12SRCNAME = "nova" 12SRCNAME = "nova"
13 13
14FILESEXTRAPATHS_append := "${THISDIR}/${PN}" 14FILESEXTRAPATHS:append := "${THISDIR}/${PN}"
15 15
16SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike \ 16SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike \
17 file://neutron-api-set-default-binding-vnic_type.patch \ 17 file://neutron-api-set-default-binding-vnic_type.patch \
@@ -46,8 +46,8 @@ USER = "nova"
46GROUP = "nova" 46GROUP = "nova"
47 47
48USERADD_PACKAGES = "${PN}" 48USERADD_PACKAGES = "${PN}"
49GROUPADD_PARAM_${PN} = "--system ${GROUP}" 49GROUPADD_PARAM:${PN} = "--system ${GROUP}"
50USERADD_PARAM_${PN} = "--system -m -d ${localstatedir}/lib/nova -s /bin/false -g ${GROUP} ${USER}" 50USERADD_PARAM:${PN} = "--system -m -d ${localstatedir}/lib/nova -s /bin/false -g ${GROUP} ${USER}"
51 51
52# Need to create the user? 52# Need to create the user?
53PLACEMENT_USER = "placement" 53PLACEMENT_USER = "placement"
@@ -82,7 +82,7 @@ python () {
82 d.setVarFlags("SERVICECREATE_PARAM_%s-ec2" % d.getVar('SRCNAME',True), flags) 82 d.setVarFlags("SERVICECREATE_PARAM_%s-ec2" % d.getVar('SRCNAME',True), flags)
83} 83}
84 84
85do_install_append() { 85do_install:append() {
86 if [ ! -f "${WORKDIR}/nova.conf" ]; then 86 if [ ! -f "${WORKDIR}/nova.conf" ]; then
87 return 87 return
88 fi 88 fi
@@ -227,37 +227,37 @@ PACKAGECONFIG ?= "bash-completion"
227PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion python-nova-bash-completion" 227PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion python-nova-bash-completion"
228 228
229PACKAGES =+ "${BPN}-bash-completion" 229PACKAGES =+ "${BPN}-bash-completion"
230FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*" 230FILES:${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
231 231
232 232
233ALLOW_EMPTY_${SRCNAME}-setup = "1" 233ALLOW_EMPTY:${SRCNAME}-setup = "1"
234ALLOW_EMPTY_${SRCNAME}-ec2 = "1" 234ALLOW_EMPTY:${SRCNAME}-ec2 = "1"
235ALLOW_EMPTY_${SRCNAME}-api = "1" 235ALLOW_EMPTY:${SRCNAME}-api = "1"
236ALLOW_EMPTY_${SRCNAME}-compute = "1" 236ALLOW_EMPTY:${SRCNAME}-compute = "1"
237ALLOW_EMPTY_${SRCNAME}-controller = "1" 237ALLOW_EMPTY:${SRCNAME}-controller = "1"
238ALLOW_EMPTY_${SRCNAME}-console = "1" 238ALLOW_EMPTY:${SRCNAME}-console = "1"
239ALLOW_EMPTY_${SRCNAME}-conductor = "1" 239ALLOW_EMPTY:${SRCNAME}-conductor = "1"
240ALLOW_EMPTY_${SRCNAME}-network = "1" 240ALLOW_EMPTY:${SRCNAME}-network = "1"
241ALLOW_EMPTY_${SRCNAME}-novncproxy = "1" 241ALLOW_EMPTY:${SRCNAME}-novncproxy = "1"
242ALLOW_EMPTY_${SRCNAME}-scheduler = "1" 242ALLOW_EMPTY:${SRCNAME}-scheduler = "1"
243ALLOW_EMPTY_${SRCNAME}-spicehtml5proxy = "1" 243ALLOW_EMPTY:${SRCNAME}-spicehtml5proxy = "1"
244 244
245 245
246 246
247FILES_${PN} = "${libdir}/*" 247FILES:${PN} = "${libdir}/*"
248 248
249# MAA FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 249# MAA FILES:${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
250FILES_${SRCNAME}-tests = "" 250FILES:${SRCNAME}-tests = ""
251 251
252FILES_${SRCNAME}-common = "${bindir}/nova-manage \ 252FILES:${SRCNAME}-common = "${bindir}/nova-manage \
253 ${bindir}/nova-rootwrap \ 253 ${bindir}/nova-rootwrap \
254 ${sysconfdir}/${SRCNAME}/* \ 254 ${sysconfdir}/${SRCNAME}/* \
255 ${sysconfdir}/sudoers.d" 255 ${sysconfdir}/sudoers.d"
256 256
257FILES_${SRCNAME}-compute = "${bindir}/nova-compute \ 257FILES:${SRCNAME}-compute = "${bindir}/nova-compute \
258 ${sysconfdir}/init.d/nova-compute" 258 ${sysconfdir}/init.d/nova-compute"
259 259
260FILES_${SRCNAME}-controller = "${bindir}/* \ 260FILES:${SRCNAME}-controller = "${bindir}/* \
261 ${sysconfdir}/init.d/nova-all " 261 ${sysconfdir}/init.d/nova-all "
262 262
263DEPENDS += " \ 263DEPENDS += " \
@@ -270,7 +270,7 @@ DEPENDS += " \
270 python-pbr-native \ 270 python-pbr-native \
271 " 271 "
272 272
273RDEPENDS_${PN} += " \ 273RDEPENDS:${PN} += " \
274 libvirt \ 274 libvirt \
275 python-pbr \ 275 python-pbr \
276 python-sqlalchemy \ 276 python-sqlalchemy \
@@ -333,10 +333,10 @@ RDEPENDS_${PN} += " \
333 python-pypowervm \ 333 python-pypowervm \
334 " 334 "
335 335
336RDEPENDS_${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \ 336RDEPENDS:${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \
337 iptables curl dnsmasq sudo procps" 337 iptables curl dnsmasq sudo procps"
338 338
339RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common \ 339RDEPENDS:${SRCNAME}-controller = "${PN} ${SRCNAME}-common \
340 ${SRCNAME}-ec2 \ 340 ${SRCNAME}-ec2 \
341 ${SRCNAME}-console \ 341 ${SRCNAME}-console \
342 ${SRCNAME}-novncproxy \ 342 ${SRCNAME}-novncproxy \
@@ -347,12 +347,12 @@ RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common \
347 ${SRCNAME}-api \ 347 ${SRCNAME}-api \
348 postgresql postgresql-client python-psycopg2" 348 postgresql postgresql-client python-psycopg2"
349 349
350RDEPENDS_${SRCNAME}-compute = "${PN} ${SRCNAME}-common python-oslo.messaging \ 350RDEPENDS:${SRCNAME}-compute = "${PN} ${SRCNAME}-common python-oslo.messaging \
351 qemu libvirt libvirt-libvirtd libvirt-python libvirt-virsh" 351 qemu libvirt libvirt-libvirtd libvirt-python libvirt-virsh"
352RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-common" 352RDEPENDS:${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-common"
353RDEPENDS_${SRCNAME}-ec2 = "postgresql sudo ${SRCNAME}-common" 353RDEPENDS:${SRCNAME}-ec2 = "postgresql sudo ${SRCNAME}-common"
354 354
355RDEPENDS_${SRCNAME}-tests = " \ 355RDEPENDS:${SRCNAME}-tests = " \
356 python-coverage \ 356 python-coverage \
357 bash \ 357 bash \
358 " 358 "
@@ -370,22 +370,22 @@ SYSTEMD_PACKAGES = " \
370 ${SRCNAME}-api \ 370 ${SRCNAME}-api \
371 " 371 "
372 372
373SYSTEMD_SERVICE_${SRCNAME}-setup = "nova-init.service" 373SYSTEMD_SERVICE:${SRCNAME}-setup = "nova-init.service"
374SYSTEMD_SERVICE_${SRCNAME}-compute = "nova-compute.service" 374SYSTEMD_SERVICE:${SRCNAME}-compute = "nova-compute.service"
375SYSTEMD_SERVICE_${SRCNAME}-console = "nova-console.service nova-consoleauth.service nova-xvpvncproxy.service" 375SYSTEMD_SERVICE:${SRCNAME}-console = "nova-console.service nova-consoleauth.service nova-xvpvncproxy.service"
376SYSTEMD_SERVICE_${SRCNAME}-novncproxy = "nova-novncproxy.service" 376SYSTEMD_SERVICE:${SRCNAME}-novncproxy = "nova-novncproxy.service"
377SYSTEMD_SERVICE_${SRCNAME}-spicehtml5proxy = "nova-spicehtml5proxy.service" 377SYSTEMD_SERVICE:${SRCNAME}-spicehtml5proxy = "nova-spicehtml5proxy.service"
378SYSTEMD_SERVICE_${SRCNAME}-network = "nova-network.service" 378SYSTEMD_SERVICE:${SRCNAME}-network = "nova-network.service"
379SYSTEMD_SERVICE_${SRCNAME}-scheduler = "nova-scheduler.service" 379SYSTEMD_SERVICE:${SRCNAME}-scheduler = "nova-scheduler.service"
380SYSTEMD_SERVICE_${SRCNAME}-conductor = "nova-conductor.service" 380SYSTEMD_SERVICE:${SRCNAME}-conductor = "nova-conductor.service"
381SYSTEMD_SERVICE_${SRCNAME}-api = "nova-api.service" 381SYSTEMD_SERVICE:${SRCNAME}-api = "nova-api.service"
382 382
383# Disable services on first boot to avoid having them run when not configured 383# Disable services on first boot to avoid having them run when not configured
384SYSTEMD_AUTO_ENABLE_${SRCNAME}-api = "disable" 384SYSTEMD_AUTO_ENABLE:${SRCNAME}-api = "disable"
385SYSTEMD_AUTO_ENABLE_${SRCNAME}-consoleauth = "disable" 385SYSTEMD_AUTO_ENABLE:${SRCNAME}-consoleauth = "disable"
386SYSTEMD_AUTO_ENABLE_${SRCNAME}-scheduler = "disable" 386SYSTEMD_AUTO_ENABLE:${SRCNAME}-scheduler = "disable"
387SYSTEMD_AUTO_ENABLE_${SRCNAME}-conductor = "disable" 387SYSTEMD_AUTO_ENABLE:${SRCNAME}-conductor = "disable"
388SYSTEMD_AUTO_ENABLE_${SRCNAME}-novncproxy = "disable" 388SYSTEMD_AUTO_ENABLE:${SRCNAME}-novncproxy = "disable"
389 389
390MONITOR_SERVICE_PACKAGES = "${SRCNAME}" 390MONITOR_SERVICE_PACKAGES = "${SRCNAME}"
391MONITOR_SERVICE_${SRCNAME} = "nova-api nova-conductor nova-console nova-scheduler" 391MONITOR_SERVICE_${SRCNAME} = "nova-api nova-conductor nova-console nova-scheduler"