summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-manilaclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-manilaclient_git.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb b/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb
deleted file mode 100644
index 2748efc..0000000
--- a/meta-openstack/recipes-devtools/python/python-manilaclient_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1DESCRIPTION = "Python bindings to the OpenStack Manila API"
2HOMEPAGE = "https://github.com/openstack/python-manilaclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9edbbf5857ab51214ef0e8b79069bb07"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
17RDEPENDS_${PN} +=" \
18 python-pbr \
19 python-iso8601 \
20 python-oslo.config \
21 python-oslo.log \
22 python-oslo.serialization \
23 python-oslo.utils \
24 python-prettytable \
25 python-pycrypto \
26 python-requests \
27 python-simplejson \
28 python-babel \
29 python-six \
30 python-keystoneclient \
31 "
32
33SRCNAME = "manilaclient"
34SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
35
36PV = "1.29.0+git${SRCPV}"
37SRCREV = "1b2cafb008bee70242b68a03212bcc575df683b9"
38S = "${WORKDIR}/git"
39
40inherit setuptools3 rmargparse