summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-magnumclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-magnumclient_git.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb b/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb
deleted file mode 100644
index 959852b..0000000
--- a/meta-openstack/recipes-devtools/python/python-magnumclient_git.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1DESCRIPTION = "Python client for containers service"
2HOMEPAGE = "https://github.com/openstack/python-magnumclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
17RDEPENDS_${PN} +=" \
18 python-pbr \
19 python-babel \
20 python-oslo.config \
21 python-oslo.i18n \
22 python-oslo.serialization \
23 python-oslo.utils \
24 python-iso8601 \
25 python-requests \
26 python-keystoneclient \
27 python-pyyaml \
28 python-stevedore \
29 python-six \
30 "
31
32SRCNAME = "magnumclient"
33SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
34
35PV = "1.0.0.0b1+git${SRCPV}"
36SRCREV = "fb1ff6777eb96a5b7ba38156bf8354cda9b88ad4"
37S = "${WORKDIR}/git"
38
39inherit setuptools3 rmargparse