summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 4bd739a..e79a6a4 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -100,7 +100,7 @@ do_install_append() {
100 100
101 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR} 101 cp -r ${S}/examples ${KEYSTONE_PACKAGE_DIR}
102 102
103 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; 103 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)};
104 then 104 then
105 install -d ${D}${sysconfdir}/init.d 105 install -d ${D}${sysconfdir}/init.d
106 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 106 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
@@ -144,7 +144,7 @@ do_install_append() {
144 -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf 144 -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf
145 fi 145 fi
146 146
147 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; 147 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)};
148 then 148 then
149 sed -i -e '/^\[identity\]/a \ 149 sed -i -e '/^\[identity\]/a \
150driver = keystone.identity.backends.hybrid_identity.Identity \ 150driver = keystone.identity.backends.hybrid_identity.Identity \
@@ -215,7 +215,7 @@ pkg_postinst_${SRCNAME}-setup () {
215 keystone-manage db_sync 215 keystone-manage db_sync
216 keystone-manage pki_setup --keystone-user=root --keystone-group=daemon 216 keystone-manage pki_setup --keystone-user=root --keystone-group=daemon
217 217
218 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then 218 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
219 /etc/init.d/openldap start 219 /etc/init.d/openldap start
220 fi 220 fi
221 /etc/init.d/keystone start 221 /etc/init.d/keystone start
@@ -292,7 +292,7 @@ RDEPENDS_${PN} += " \
292 292
293RDEPENDS_${SRCNAME}-tests += " bash" 293RDEPENDS_${SRCNAME}-tests += " bash"
294 294
295PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}" 295PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
296PACKAGECONFIG[OpenLDAP] = ",,,python-ldap python-keystone-hybrid-backend" 296PACKAGECONFIG[OpenLDAP] = ",,,python-ldap python-keystone-hybrid-backend"
297 297
298# TODO: 298# TODO: