summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-horizon_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-horizon_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 26afe40..9e36656 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -14,7 +14,7 @@ DEPENDS += " \
14 python-pbr-native \ 14 python-pbr-native \
15 " 15 "
16 16
17RDEPENDS_${PN} += " \ 17RDEPENDS:${PN} += " \
18 python-pbr \ 18 python-pbr \
19 python-babel \ 19 python-babel \
20 python-django \ 20 python-django \
@@ -96,13 +96,13 @@ USER = "horizon"
96GROUP = "horizon" 96GROUP = "horizon"
97 97
98USERADD_PACKAGES = "${PN}" 98USERADD_PACKAGES = "${PN}"
99GROUPADD_PARAM_${PN} = "--system ${GROUP}" 99GROUPADD_PARAM:${PN} = "--system ${GROUP}"
100USERADD_PARAM_${PN} = "--system -m -d ${localstatedir}/lib/openstack-dashboard -s /bin/false -g ${GROUP} ${USER}" 100USERADD_PARAM:${PN} = "--system -m -d ${localstatedir}/lib/openstack-dashboard -s /bin/false -g ${GROUP} ${USER}"
101 101
102# no longer required. kept as reference. 102# no longer required. kept as reference.
103# do_install[dirs] += "${D}/usr/share/bin" 103# do_install[dirs] += "${D}/usr/share/bin"
104 104
105do_install_append() { 105do_install:append() {
106 SYSCONF_DIR=${D}${sysconfdir} 106 SYSCONF_DIR=${D}${sysconfdir}
107 DASHBOARD_CONF_DIR=${SYSCONF_DIR}/openstack-dashboard 107 DASHBOARD_CONF_DIR=${SYSCONF_DIR}/openstack-dashboard
108 DASHBOARD_SHARE_DIR=${D}${datadir}/openstack-dashboard 108 DASHBOARD_SHARE_DIR=${D}${datadir}/openstack-dashboard
@@ -163,7 +163,7 @@ do_install_append() {
163 ln -fs openstack_dashboard/static ${DASHBOARD_SHARE_DIR}/static 163 ln -fs openstack_dashboard/static ${DASHBOARD_SHARE_DIR}/static
164} 164}
165 165
166pkg_postinst_${SRCNAME} () { 166pkg_postinst:${SRCNAME} () {
167 if [ -n "$D" ]; then 167 if [ -n "$D" ]; then
168 exit 1 168 exit 1
169 else 169 else
@@ -173,39 +173,39 @@ pkg_postinst_${SRCNAME} () {
173} 173}
174 174
175PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-apache ${SRCNAME}-standalone" 175PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-apache ${SRCNAME}-standalone"
176ALLOW_EMPTY_${SRCNAME}-standalone = "1" 176ALLOW_EMPTY:${SRCNAME}-standalone = "1"
177 177
178RDEPENDS_${SRCNAME}-tests += " bash" 178RDEPENDS:${SRCNAME}-tests += " bash"
179 179
180FILES_${PN} = "${libdir}/*" 180FILES:${PN} = "${libdir}/*"
181 181
182FILES_${SRCNAME}-tests = "${sysconfdir}/openstack-dashboard/run_tests.sh" 182FILES:${SRCNAME}-tests = "${sysconfdir}/openstack-dashboard/run_tests.sh"
183 183
184FILES_${SRCNAME} = "${bindir}/* \ 184FILES:${SRCNAME} = "${bindir}/* \
185 ${datadir}/* \ 185 ${datadir}/* \
186 " 186 "
187 187
188FILES_${SRCNAME}-standalone = "${sysconfdir}/init.d/horizon" 188FILES:${SRCNAME}-standalone = "${sysconfdir}/init.d/horizon"
189 189
190FILES_${SRCNAME}-apache = " \ 190FILES:${SRCNAME}-apache = " \
191 ${sysconfdir}/apache2 \ 191 ${sysconfdir}/apache2 \
192 ${sysconfdir}/openstack-dashboard/ \ 192 ${sysconfdir}/openstack-dashboard/ \
193 ${datadir}/openstack-dashboard/ \ 193 ${datadir}/openstack-dashboard/ \
194 " 194 "
195 195
196RDEP_ARCH_VAR = "" 196RDEP_ARCH_VAR = ""
197RDEP_ARCH_VAR_arm = "nodejs" 197RDEP_ARCH_VAR:arm = "nodejs"
198RDEP_ARCH_VAR_i686 = "nodejs" 198RDEP_ARCH_VAR_i686 = "nodejs"
199RDEP_ARCH_VAR_x86-64 = "nodejs" 199RDEP_ARCH_VAR:x86-64 = "nodejs"
200RDEP_ARCH_VAR_ia32 = "nodejs" 200RDEP_ARCH_VAR_ia32 = "nodejs"
201 201
202RDEPENDS_${PN} += " \ 202RDEPENDS:${PN} += " \
203 ${RDEP_ARCH_VAR} \ 203 ${RDEP_ARCH_VAR} \
204 " 204 "
205 205
206RDEPENDS_${SRCNAME} = "${PN}" 206RDEPENDS:${SRCNAME} = "${PN}"
207 207
208RDEPENDS_${SRCNAME}-apache = "\ 208RDEPENDS:${SRCNAME}-apache = "\
209 apache2 \ 209 apache2 \
210 mod-wsgi \ 210 mod-wsgi \
211 python-lesscpy \ 211 python-lesscpy \