summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-flake8_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-flake8_2.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-flake8_2.4.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-flake8_2.4.0.bb b/meta-openstack/recipes-devtools/python/python-flake8_2.4.0.bb
new file mode 100644
index 0000000..7a065b9
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-flake8_2.4.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "The modular source code checker: pep8, pyflakes and co"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a76e57e683629e1ac2a49406169c2a3"
6
7SRCNAME = "flake8"
8
9SRC_URI = "https://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "d413935bb21026c18aca82654114502f"
12SRC_URI[sha256sum] = "d26a9d0252da9f831b8277b824961bb10b1f9d79f4752d32e4814b7bcd1e089b"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} += "python-prettytable \
19 python-cmd2 \
20 python-pyparsing \
21 python-mccabe \
22 python-pep8 \
23 python-pyflakes"