summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cursive_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cursive_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cursive_git.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cursive_git.bb b/meta-openstack/recipes-devtools/python/python-cursive_git.bb
deleted file mode 100644
index ce82998..0000000
--- a/meta-openstack/recipes-devtools/python/python-cursive_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Library for validation of digital signatures."
2HOMEPAGE = "https://github.com/openstack/cursive"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://git.openstack.org/openstack/cursive.git;branch=master \
9 "
10
11PV="0.2.0+git${SRCPV}"
12SRCREV="ad25a4016c56eeceb85764c7ac4501def2b5445a"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python-pbr \
28 python-lxml \
29 python-cryptography \
30 python-netifaces \
31 python-six \
32 python-oslo.serialization \
33 python-oslo.utils \
34 python-oslo.i18n \
35 python-oslo.log \
36 python-castellan \
37 "