summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-barbican_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-barbican_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index 8908e20..85ab146 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -40,7 +40,7 @@ python () {
40} 40}
41SERVICECREATE_PACKAGES[vardeps] += "KEYSTONE_HOST" 41SERVICECREATE_PACKAGES[vardeps] += "KEYSTONE_HOST"
42 42
43do_install_append() { 43do_install:append() {
44 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME} 44 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
45 BARBICAN_CONF_DIR=${D}${sysconfdir}/${SRCNAME} 45 BARBICAN_CONF_DIR=${D}${sysconfdir}/${SRCNAME}
46 46
@@ -67,24 +67,24 @@ do_install_append() {
67} 67}
68 68
69USERADD_PACKAGES = "${PN}" 69USERADD_PACKAGES = "${PN}"
70GROUPADD_PARAM_${PN} = "--system barbican" 70GROUPADD_PARAM:${PN} = "--system barbican"
71USERADD_PARAM_${PN} = "--system --home /var/lib/barbican -g barbican \ 71USERADD_PARAM:${PN} = "--system --home /var/lib/barbican -g barbican \
72 --no-create-home --shell /bin/false barbican" 72 --no-create-home --shell /bin/false barbican"
73 73
74PACKAGES += "${SRCNAME} \ 74PACKAGES += "${SRCNAME} \
75 ${SRCNAME}-setup " 75 ${SRCNAME}-setup "
76 76
77FILES_${PN} = "${libdir}/* \ 77FILES:${PN} = "${libdir}/* \
78" 78"
79FILES_${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \ 79FILES:${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \
80 ${sysconfdir}/init.d/barbican-api \ 80 ${sysconfdir}/init.d/barbican-api \
81 ${bindir} \ 81 ${bindir} \
82 ${bindir}/* \ 82 ${bindir}/* \
83 ${localstatedir}/* \ 83 ${localstatedir}/* \
84" 84"
85 85
86ALLOW_EMPTY_${SRCNAME}-setup = "1" 86ALLOW_EMPTY:${SRCNAME}-setup = "1"
87pkg_postinst_${SRCNAME}-setup () { 87pkg_postinst:${SRCNAME}-setup () {
88 if [ -z "$D" ]; then 88 if [ -z "$D" ]; then
89 chown -R barbican:barbican ${sysconfdir}/${SRCNAME} 89 chown -R barbican:barbican ${sysconfdir}/${SRCNAME}
90 chown -R barbican:barbican ${localstatedir}/lib/barbican 90 chown -R barbican:barbican ${localstatedir}/lib/barbican
@@ -101,13 +101,13 @@ DEPENDS += " \
101 python-pbr-native \ 101 python-pbr-native \
102 " 102 "
103 103
104RDEPENDS_${SRCNAME} = "${PN} \ 104RDEPENDS:${SRCNAME} = "${PN} \
105 ${SRCNAME}-setup \ 105 ${SRCNAME}-setup \
106 uwsgi \ 106 uwsgi \
107 python-falcon \ 107 python-falcon \
108 python-oslo.messaging" 108 python-oslo.messaging"
109 109
110RDEPENDS_${PN} += " \ 110RDEPENDS:${PN} += " \
111 python-pip \ 111 python-pip \
112 python-pbr \ 112 python-pbr \
113 python-alembic \ 113 python-alembic \
@@ -131,8 +131,8 @@ RDEPENDS_${PN} += " \
131 " 131 "
132 132
133INITSCRIPT_PACKAGES = "${SRCNAME}" 133INITSCRIPT_PACKAGES = "${SRCNAME}"
134INITSCRIPT_NAME_${SRCNAME} = "barbican-api" 134INITSCRIPT_NAME:${SRCNAME} = "barbican-api"
135INITSCRIPT_PARAMS_${SRCNAME} = "${OS_DEFAULT_INITSCRIPT_PARAMS}" 135INITSCRIPT_PARAMS:${SRCNAME} = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
136 136
137MONITOR_SERVICE_PACKAGES = "${SRCNAME}" 137MONITOR_SERVICE_PACKAGES = "${SRCNAME}"
138MONITOR_SERVICE_${SRCNAME} = "barbican" 138MONITOR_SERVICE_${SRCNAME} = "barbican"