summaryrefslogtreecommitdiffstats
path: root/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend')
-rw-r--r--meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend b/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend
new file mode 100644
index 0000000..1c89d51
--- /dev/null
+++ b/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend
@@ -0,0 +1,16 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://glance-test-config.init"
4
5do_install_append() {
6 install -m 0755 ${WORKDIR}/glance-test-config.init ${D}${sysconfdir}/init.d/glance-test-config
7}
8
9PACKAGES += " ${SRCNAME}-test-config"
10FILES_${SRCNAME}-test-config = "${sysconfdir}/init.d/glance-test-config"
11
12RDEPENDS_${SRCNAME}-tests += " ${SRCNAME}-test-config"
13
14INITSCRIPT_PACKAGES += " ${SRCNAME}-test-config"
15INITSCRIPT_NAME_${SRCNAME}-test-config = "glance-test-config"
16INITSCRIPT_PARAMS_${SRCNAME}-test-config = "defaults 95 10"