summaryrefslogtreecommitdiffstats
path: root/meta-openstack-controller-test-config/recipes-devtools/python/python-cinder_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack-controller-test-config/recipes-devtools/python/python-cinder_git.bbappend')
-rw-r--r--meta-openstack-controller-test-config/recipes-devtools/python/python-cinder_git.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack-controller-test-config/recipes-devtools/python/python-cinder_git.bbappend b/meta-openstack-controller-test-config/recipes-devtools/python/python-cinder_git.bbappend
new file mode 100644
index 0000000..5003336
--- /dev/null
+++ b/meta-openstack-controller-test-config/recipes-devtools/python/python-cinder_git.bbappend
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://cinder-test-config.init"
4
5do_install_prepend() {
6 # Remove nfs cinder-volume backend driver
7 sed -e "s/nfsdriver,//" -i ${WORKDIR}/cinder.conf
8}
9
10do_install_append() {
11 install -m 0755 ${WORKDIR}/cinder-test-config.init ${D}${sysconfdir}/init.d/cinder-test-config
12}
13
14PACKAGES += " ${SRCNAME}-test-config"
15FILES_${SRCNAME}-test-config = "${sysconfdir}/init.d/cinder-test-config"
16
17RDEPENDS_${SRCNAME}-tests += " ${SRCNAME}-test-config"
18
19INITSCRIPT_PACKAGES += " ${SRCNAME}-test-config"
20INITSCRIPT_NAME_${SRCNAME}-test-config = "cinder-test-config"
21INITSCRIPT_PARAMS_${SRCNAME}-test-config = "defaults 95 10"