summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg21
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc4
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend5
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend5
4 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg
new file mode 100644
index 0000000..6e1cff7
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.cfg
@@ -0,0 +1,21 @@
1CONFIG_NF_NAT=m
2CONFIG_NF_NAT_NEEDED=y
3CONFIG_NF_NAT_PROTO_UDPLITE=m
4CONFIG_NF_NAT_PROTO_SCTP=m
5CONFIG_NF_NAT_AMANDA=m
6CONFIG_NF_NAT_FTP=m
7CONFIG_NF_NAT_IRC=m
8CONFIG_NF_NAT_SIP=m
9CONFIG_NF_NAT_TFTP=m
10
11CONFIG_NETFILTER_XT_TARGET_NETMAP=m
12
13CONFIG_NETFILTER_XT_TARGET_REDIRECT=m
14
15CONFIG_NF_NAT_IPV4=m
16CONFIG_IP_NF_TARGET_MASQUERADE=m
17CONFIG_IP_NF_TARGET_NETMAP=m
18CONFIG_IP_NF_TARGET_REDIRECT=m
19CONFIG_NF_NAT_PROTO_GRE=m
20CONFIG_NF_NAT_PPTP=m
21CONFIG_NF_NAT_H323=m
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc
new file mode 100644
index 0000000..9faf22e
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto/iptables-nat.scc
@@ -0,0 +1,4 @@
1define KFEATURE_DESCRIPTION "Enable iptables nat"
2define KFEATURE_COMPATIBILITY board
3
4kconf non-hardware iptables-nat.cfg
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000..02bf487
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PRINC := "${@int(PRINC) + 1}"
3
4SRC_URI += "file://iptables-nat.scc"
5
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 0000000..02bf487
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PRINC := "${@int(PRINC) + 1}"
3
4SRC_URI += "file://iptables-nat.scc"
5