summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-connectivity/openssh/openssh_6.7p1.bbappend (renamed from meta-openstack/recipes-connectivity/openssh/openssh_6.6p1.bbappend)0
-rw-r--r--meta-openstack/recipes-containers/lxc/lxc_1.0.7.bbappend (renamed from meta-openstack/recipes-containers/lxc/lxc_1.0.6.bbappend)0
-rw-r--r--meta-openstack/recipes-core/busybox/busybox_1.23.1.bbappend (renamed from meta-openstack/recipes-core/busybox/busybox_1.22.1.bbappend)0
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch105
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch32
-rw-r--r--meta-openstack/recipes-devtools/qemu/qemu_2.2.0.bbappend (renamed from meta-openstack/recipes-devtools/qemu/qemu_2.1.0.bbappend)0
-rw-r--r--meta-openstack/recipes-extended/libvirt/libvirt_1.2.12.bbappend (renamed from meta-openstack/recipes-extended/libvirt/libvirt_1.2.8.bbappend)0
-rw-r--r--meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.1.bbappend (renamed from meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.bbappend)0
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend5
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend9
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_3.17.0.bbappend (renamed from meta-openstack/recipes-support/iproute2/iproute2_3.16.0.bbappend)0
-rw-r--r--meta-openstack/recipes-support/xmlto/xmlto_0.0.26.bbappend (renamed from meta-openstack/recipes-support/xmlto/xmlto_0.0.25.bbappend)0
12 files changed, 9 insertions, 142 deletions
diff --git a/meta-openstack/recipes-connectivity/openssh/openssh_6.6p1.bbappend b/meta-openstack/recipes-connectivity/openssh/openssh_6.7p1.bbappend
index bfc543a..bfc543a 100644
--- a/meta-openstack/recipes-connectivity/openssh/openssh_6.6p1.bbappend
+++ b/meta-openstack/recipes-connectivity/openssh/openssh_6.7p1.bbappend
diff --git a/meta-openstack/recipes-containers/lxc/lxc_1.0.6.bbappend b/meta-openstack/recipes-containers/lxc/lxc_1.0.7.bbappend
index 7447c56..7447c56 100644
--- a/meta-openstack/recipes-containers/lxc/lxc_1.0.6.bbappend
+++ b/meta-openstack/recipes-containers/lxc/lxc_1.0.7.bbappend
diff --git a/meta-openstack/recipes-core/busybox/busybox_1.22.1.bbappend b/meta-openstack/recipes-core/busybox/busybox_1.23.1.bbappend
index 569bd30..569bd30 100644
--- a/meta-openstack/recipes-core/busybox/busybox_1.22.1.bbappend
+++ b/meta-openstack/recipes-core/busybox/busybox_1.23.1.bbappend
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch
deleted file mode 100644
index 37688d6..0000000
--- a/meta-openstack/recipes-devtools/python/python-novaclient/fix_novaclient_memory_leak.patch
+++ /dev/null
@@ -1,105 +0,0 @@
1---
2 novaclient/client.py | 10 ++++++++++
3 novaclient/openstack/common/apiclient/client.py | 10 ++++++++++
4 novaclient/v1_1/client.py | 6 ++++++
5 novaclient/v3/client.py | 6 ++++++
6 4 files changed, 32 insertions(+)
7
8Index: git/novaclient/client.py
9===================================================================
10--- git.orig/novaclient/client.py
11+++ git/novaclient/client.py
12@@ -266,6 +266,7 @@
13 self.timeout = None
14
15 self.times = [] # [("item", starttime, endtime), ...]
16+ self.times_max_len = 200
17
18 self.management_url = self.bypass_url or None
19 self.auth_token = auth_token
20@@ -328,6 +329,12 @@
21 else:
22 return name, value
23
24+ def get_timings_max_len(self):
25+ return self.times_max_len
26+
27+ def set_timings_max_len(self, new_len):
28+ self.times_max_len = new_len
29+
30 def http_log_req(self, method, url, kwargs):
31 if not self.http_log_debug:
32 return
33@@ -441,6 +448,9 @@
34 resp, body = self.request(url, method, **kwargs)
35 self.times.append(("%s %s" % (method, url),
36 start_time, time.time()))
37+ # remove oldest items until we maintain max length
38+ while len(self.times) > self.times_max_len:
39+ del self.times[0]
40 return resp, body
41
42 def _cs_request(self, url, method, **kwargs):
43Index: git/novaclient/openstack/common/apiclient/client.py
44===================================================================
45--- git.orig/novaclient/openstack/common/apiclient/client.py
46+++ git/novaclient/openstack/common/apiclient/client.py
47@@ -92,6 +92,7 @@
48 self.user_agent = user_agent or self.user_agent
49
50 self.times = [] # [("item", starttime, endtime), ...]
51+ self.times_max_len = 200
52 self.timings = timings
53
54 # requests within the same session can reuse TCP connections from pool
55@@ -144,6 +145,12 @@
56 def reset_timings(self):
57 self.times = []
58
59+ def get_timings_max_len(self):
60+ return self.times_max_len
61+
62+ def set_timings_max_len(self, new_len):
63+ self.times_max_len = new_len
64+
65 def request(self, method, url, **kwargs):
66 """Send an http request with the specified characteristics.
67
68@@ -175,6 +182,9 @@
69 if self.timings:
70 self.times.append(("%s %s" % (method, url),
71 start_time, time.time()))
72+ # remove oldest items until we maintain max length
73+ while len(self.times) > self.times_max_len:
74+ del self.times[0]
75 self._http_log_resp(resp)
76
77 if resp.status_code >= 400:
78Index: git/novaclient/v1_1/client.py
79===================================================================
80--- git.orig/novaclient/v1_1/client.py
81+++ git/novaclient/v1_1/client.py
82@@ -232,3 +232,9 @@
83 credentials are wrong.
84 """
85 self.client.authenticate()
86+
87+ def get_timings_max_len(self):
88+ return self.client.get_timings_max_len()
89+
90+ def set_timings_max_len(self, new_len):
91+ self.client.set_timings_max_len(new_len)
92Index: git/novaclient/v3/client.py
93===================================================================
94--- git.orig/novaclient/v3/client.py
95+++ git/novaclient/v3/client.py
96@@ -194,3 +194,9 @@
97 credentials are wrong.
98 """
99 self.client.authenticate()
100+
101+ def get_timings_max_len(self):
102+ return self.client.get_timings_max_len()
103+
104+ def set_timings_max_len(self, new_len):
105+ self.client.set_timings_max_len(new_len)
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch b/meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch
deleted file mode 100644
index 1cee4d0..0000000
--- a/meta-openstack/recipes-devtools/python/python-novaclient/novaclient-specify-full-path-to-test-certificate.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From bdd853d38c7b14088d3e6368e298201c249ab004 Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Fri, 13 Jun 2014 09:54:41 -0400
4Subject: [PATCH] novaclient: specify full path to test certificate
5
6The tests shipped with novaclient assume that the files
7exist at the same location as are appear within the
8source tree. The tests also assume that the test is ran
9from the root of the tree. This causes a test to fail as
10it can't find a test certificate used in one of the
11tests. This patch fixes the affected test by putting in
12an identifier that is replaced with the full path to the
13certificate file.
14
15Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
16---
17 novaclient/tests/v1_1/test_servers.py | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20Index: git/novaclient/tests/v1_1/test_servers.py
21===================================================================
22--- git.orig/novaclient/tests/v1_1/test_servers.py
23+++ git/novaclient/tests/v1_1/test_servers.py
24@@ -501,7 +501,7 @@
25 def test_get_password(self):
26 s = self.cs.servers.get(1234)
27 self.assertEqual(b'FooBar123',
28- s.get_password('novaclient/tests/idfake.pem'))
29+ s.get_password('%PYTHON_SITEPACKAGES_DIR%/novaclient/tests/idfake.pem'))
30 self.assert_called('GET', '/servers/1234/os-server-password')
31
32 def test_get_password_without_key(self):
diff --git a/meta-openstack/recipes-devtools/qemu/qemu_2.1.0.bbappend b/meta-openstack/recipes-devtools/qemu/qemu_2.2.0.bbappend
index 1c8c682..1c8c682 100644
--- a/meta-openstack/recipes-devtools/qemu/qemu_2.1.0.bbappend
+++ b/meta-openstack/recipes-devtools/qemu/qemu_2.2.0.bbappend
diff --git a/meta-openstack/recipes-extended/libvirt/libvirt_1.2.8.bbappend b/meta-openstack/recipes-extended/libvirt/libvirt_1.2.12.bbappend
index 195633b..195633b 100644
--- a/meta-openstack/recipes-extended/libvirt/libvirt_1.2.8.bbappend
+++ b/meta-openstack/recipes-extended/libvirt/libvirt_1.2.12.bbappend
diff --git a/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.bbappend b/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.1.bbappend
index 8da640f..8da640f 100644
--- a/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.bbappend
+++ b/meta-openstack/recipes-extended/sysklogd/sysklogd_1.5.1.bbappend
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 955716b..0000000
--- a/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://iscsi-tcp.scc \
4 file://enable-iscsi-tcp.cfg \
5 "
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend
new file mode 100644
index 0000000..843546c
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.19.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://enable-veth.cfg \
4 file://enable-iscsi-tcp.cfg \
5 file://enable-nbd.cfg \
6 file://enable-rtlink.cfg \
7 file://nf.scc \
8 file://nfs.scc \
9 "
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_3.16.0.bbappend b/meta-openstack/recipes-support/iproute2/iproute2_3.17.0.bbappend
index 8949646..8949646 100644
--- a/meta-openstack/recipes-support/iproute2/iproute2_3.16.0.bbappend
+++ b/meta-openstack/recipes-support/iproute2/iproute2_3.17.0.bbappend
diff --git a/meta-openstack/recipes-support/xmlto/xmlto_0.0.25.bbappend b/meta-openstack/recipes-support/xmlto/xmlto_0.0.26.bbappend
index 7447c56..7447c56 100644
--- a/meta-openstack/recipes-support/xmlto/xmlto_0.0.25.bbappend
+++ b/meta-openstack/recipes-support/xmlto/xmlto_0.0.26.bbappend