summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova/nova-fix-location-to-doc-directory.patch46
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb3
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova/nova-fix-location-to-doc-directory.patch b/meta-openstack/recipes-devtools/python/python-nova/nova-fix-location-to-doc-directory.patch
new file mode 100644
index 0000000..7893f87
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-nova/nova-fix-location-to-doc-directory.patch
@@ -0,0 +1,46 @@
1From 4d74c926b8dd7eaac0c9ddac0d1161f634b69e1d Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Tue, 17 Jun 2014 16:40:51 -0400
4Subject: [PATCH] nova: fix location to doc directory
5
6Currently, the tests included with nova expect the doc directory to be
7in the location they exist in the source tree. However, during system
8deployment the documentation is installed under the "nova" directory 1
9level higher in the directory tree. This patch fixes the relative
10path to be able to find the files.
11
12Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
13---
14 nova/tests/integrated/api_samples_test_base.py | 2 +-
15 nova/tests/integrated/v3/api_sample_base.py | 2 +-
16 2 files changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/nova/tests/integrated/api_samples_test_base.py b/nova/tests/integrated/api_samples_test_base.py
19index 6acb5a1..31caa6c 100644
20--- a/nova/tests/integrated/api_samples_test_base.py
21+++ b/nova/tests/integrated/api_samples_test_base.py
22@@ -88,7 +88,7 @@ class ApiSampleTestBase(integrated_helpers._IntegratedTestBase):
23 @classmethod
24 def _get_sample(cls, name):
25 dirname = os.path.dirname(os.path.abspath(__file__))
26- dirname = os.path.normpath(os.path.join(dirname, "../../../doc"))
27+ dirname = os.path.normpath(os.path.join(dirname, "../../doc"))
28 return cls._get_sample_path(name, dirname)
29
30 @classmethod
31diff --git a/nova/tests/integrated/v3/api_sample_base.py b/nova/tests/integrated/v3/api_sample_base.py
32index aa1ca8f..d22a2c8 100644
33--- a/nova/tests/integrated/v3/api_sample_base.py
34+++ b/nova/tests/integrated/v3/api_sample_base.py
35@@ -71,7 +71,7 @@ class ApiSampleTestBaseV3(api_samples_test_base.ApiSampleTestBase):
36 @classmethod
37 def _get_sample(cls, name):
38 dirname = os.path.dirname(os.path.abspath(__file__))
39- dirname = os.path.normpath(os.path.join(dirname, "../../../../doc/v3"))
40+ dirname = os.path.normpath(os.path.join(dirname, "../../../doc/v3"))
41 return cls._get_sample_path(name, dirname)
42
43 @classmethod
44--
451.9.3
46
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index a6d5fc8..46aa561 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -14,6 +14,7 @@ FILESEXTRAPATHS := "${THISDIR}/${PN}"
14SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \ 14SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \
15 file://nova-add-migrate.cfg-to-the-MANIFEST.patch \ 15 file://nova-add-migrate.cfg-to-the-MANIFEST.patch \
16 file://nova-convert-path-from-relative-to-absolute.patch \ 16 file://nova-convert-path-from-relative-to-absolute.patch \
17 file://nova-fix-location-to-doc-directory.patch \
17 " 18 "
18 19
19SRC_URI += "file://nova-all \ 20SRC_URI += "file://nova-all \
@@ -121,6 +122,8 @@ do_install_append() {
121 122
122 install -d ${D}/${sysconfdir}/bash_completion.d 123 install -d ${D}/${sysconfdir}/bash_completion.d
123 install -m 664 ${S}/tools/nova-manage.bash_completion ${D}/${sysconfdir}/bash_completion.d 124 install -m 664 ${S}/tools/nova-manage.bash_completion ${D}/${sysconfdir}/bash_completion.d
125
126 cp -r "${S}/doc" "${D}/${PYTHON_SITEPACKAGES_DIR}/nova"
124} 127}
125 128
126pkg_postinst_${SRCNAME}-setup () { 129pkg_postinst_${SRCNAME}-setup () {