summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.db_git.bb38
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.db_git.bb38
2 files changed, 38 insertions, 38 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
deleted file mode 100644
index a330ed4..0000000
--- a/meta-openstack/recipes-devtools/python/python-oslo.db_git.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "oslo.db library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "4.25.0+git${SRCPV}"
8SRCREV = "71607d59ec5c02d7beb5109c500aa9b6a0d9ee2c"
9
10SRCNAME = "oslo.db"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
27RDEPENDS_${PN} += " \
28 python-six \
29 python-alembic \
30 python-oslo.config \
31 python-oslo.i18n \
32 python-oslo.utils \
33 python-sqlalchemy \
34 python-sqlalchemy-migrate \
35 python-stevedore \
36 python-pbr \
37 python-debtcollector \
38 "
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.db_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.db_git.bb
new file mode 100644
index 0000000..3a78391
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.db_git.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "oslo.db library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "8.4.0+git${SRCPV}"
8SRCREV = "e42c73343f640eaacb0a76d204eb55c85de4f5d5"
9
10SRCNAME = "oslo.db"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python3-pip \
19 python3-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python3-pbr-native \
25 "
26
27RDEPENDS_${PN} += " \
28 python3-six \
29 python3-alembic \
30 python3-oslo.config \
31 python3-oslo.i18n \
32 python3-oslo.utils \
33 python3-sqlalchemy \
34 python3-sqlalchemy-migrate \
35 python3-stevedore \
36 python3-pbr \
37 python3-debtcollector \
38 "