summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf10
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone/identity.sh1
3 files changed, 7 insertions, 6 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf b/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf
index 457199d..abeb65c 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf
@@ -718,14 +718,14 @@ os_auth_url=http://%CONTROLLER_IP%:5000/v2.0
718 718
719# Host providing the admin Identity API endpoint (string 719# Host providing the admin Identity API endpoint (string
720# value) 720# value)
721#auth_host=127.0.0.1 721auth_host=%CONTROLLER_IP%
722 722
723# Port of the admin Identity API endpoint (integer value) 723# Port of the admin Identity API endpoint (integer value)
724#auth_port=35357 724#auth_port=35357
725 725
726# Protocol of the admin Identity API endpoint(http or https) 726# Protocol of the admin Identity API endpoint(http or https)
727# (string value) 727# (string value)
728#auth_protocol=https 728auth_protocol=http
729 729
730# Complete public Identity API endpoint (string value) 730# Complete public Identity API endpoint (string value)
731#auth_uri=<None> 731#auth_uri=<None>
@@ -759,14 +759,14 @@ os_auth_url=http://%CONTROLLER_IP%:5000/v2.0
759#admin_token=<None> 759#admin_token=<None>
760 760
761# Keystone account username (string value) 761# Keystone account username (string value)
762#admin_user=<None> 762admin_user=ceilometer
763 763
764# Keystone account password (string value) 764# Keystone account password (string value)
765#admin_password=<None> 765admin_password=%ADMIN_PASSWORD%
766 766
767# Keystone service account tenant name to validate user tokens 767# Keystone service account tenant name to validate user tokens
768# (string value) 768# (string value)
769#admin_tenant_name=admin 769admin_tenant_name=%SERVICE_TENANT_NAME%
770 770
771# Env key for the swift cache (string value) 771# Env key for the swift cache (string value)
772#cache=<None> 772#cache=<None>
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
index c0d3df4..7362733 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
@@ -17,7 +17,7 @@ PR = "r0"
17SRC_URI = "git://github.com/openstack/python-ceilometerclient.git;branch=master" 17SRC_URI = "git://github.com/openstack/python-ceilometerclient.git;branch=master"
18 18
19PV="1.0.6+git${SRCPV}" 19PV="1.0.6+git${SRCPV}"
20SRCREV="067b76d9a821c3acb60d93787396d25b729a7421" 20SRCREV="4c42f5052678539648a1051a526b82ab95269a2b"
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23inherit setuptools 23inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-keystone/identity.sh b/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
index edf29ef..bf5aca7 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
+++ b/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
@@ -143,6 +143,7 @@ keystone user-role-list --user-id $DEMO_USER --tenant-id $DEMO_TENANT &> /dev/nu
143keystone user-role-add --tenant-id $DEMO_TENANT --user-id $DEMO_USER --role-id $MEMBER_ROLE 143keystone user-role-add --tenant-id $DEMO_TENANT --user-id $DEMO_USER --role-id $MEMBER_ROLE
144 144
145keystone user-role-list --user-id $CEILOMETER_USER --tenant_id $SERVICE_TENANT &> /dev/null 145keystone user-role-list --user-id $CEILOMETER_USER --tenant_id $SERVICE_TENANT &> /dev/null
146keystone user-role-add --tenant-id $SERVICE_TENANT --user-id $CEILOMETER_USER --role-id $ADMIN_ROLE
146keystone user-role-add --tenant_id $SERVICE_TENANT --user_id $CEILOMETER_USER --role-id $RESELLER_ADMIN_ROLE 147keystone user-role-add --tenant_id $SERVICE_TENANT --user_id $CEILOMETER_USER --role-id $RESELLER_ADMIN_ROLE
147 148
148keystone user-role-add --tenant_id $SERVICE_TENANT --user-id $HEAT_USER --role-id $ADMIN_ROLE 149keystone user-role-add --tenant_id $SERVICE_TENANT --user-id $HEAT_USER --role-id $ADMIN_ROLE