summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-pytest-salt.inc21
-rw-r--r--meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb23
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pytest-salt_2017.7.0.bb2
3 files changed, 24 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pytest-salt.inc b/meta-openstack/recipes-devtools/python/python-pytest-salt.inc
new file mode 100644
index 0000000..1f82763
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pytest-salt.inc
@@ -0,0 +1,21 @@
1SUMMARY = "This pytest plugin will allow the Salt Daemons to be used in tests."
2HOMEPAGE = "https://github.com/saltstack/pytest-salt"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
6
7SRCNAME = "pytest-salt"
8SRC_URI = "git://github.com/saltstack/${SRCNAME}.git;branch=master"
9
10SRC_URI[md5sum] = "c598d7db87ea52cdeb067d7596b3b0b1"
11SRC_URI[sha256sum] = "7052459cda9fbdbbfff9a25b24243b0b96cf56835a2c41135d754cc5b65e2494"
12
13SRCREV = "feb5031f80cf84b113ebe69543cdd44b6a373d21"
14S = "${WORKDIR}/git"
15
16RDEPENDS_${PN} = " \
17 ${PYTHON_PN}-pytest \
18 ${PYTHON_PN}-pytest-tempdir \
19 ${PYTHON_PN}-pytest-helpers-namespace \
20 ${PYTHON_PN}-psutil \
21 "
diff --git a/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb b/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
index e2cf1cd..e599e77 100644
--- a/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
@@ -1,23 +1,2 @@
1SUMMARY = "This pytest plugin will allow the Salt Daemons to be used in tests." 1require python-pytest-salt.inc
2HOMEPAGE = "https://github.com/saltstack/pytest-salt"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
6
7SRCNAME = "pytest-salt"
8SRC_URI = "git://github.com/saltstack/${SRCNAME}.git;branch=master"
9
10SRC_URI[md5sum] = "c598d7db87ea52cdeb067d7596b3b0b1"
11SRC_URI[sha256sum] = "7052459cda9fbdbbfff9a25b24243b0b96cf56835a2c41135d754cc5b65e2494"
12
13SRCREV = "feb5031f80cf84b113ebe69543cdd44b6a373d21"
14S = "${WORKDIR}/git"
15
16inherit setuptools 2inherit setuptools
17
18RDEPENDS_${PN} = " \
19 python-pytest \
20 python-pytest-tempdir \
21 python-pytest-helpers-namespace \
22 python-psutil \
23 "
diff --git a/meta-openstack/recipes-devtools/python/python3-pytest-salt_2017.7.0.bb b/meta-openstack/recipes-devtools/python/python3-pytest-salt_2017.7.0.bb
new file mode 100644
index 0000000..4e33265
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pytest-salt_2017.7.0.bb
@@ -0,0 +1,2 @@
1require python-pytest-salt.inc
2inherit setuptools3