summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-simplegeneric.inc12
-rw-r--r--meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb14
-rw-r--r--meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb2
3 files changed, 16 insertions, 12 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-simplegeneric.inc b/meta-openstack/recipes-devtools/python/python-simplegeneric.inc
new file mode 100644
index 0000000..2cd9fc0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-simplegeneric.inc
@@ -0,0 +1,12 @@
1DESCRIPTION = "Simple generic functions"
2HOMEPAGE = "https://pypi.python.org/pypi/simplegeneric/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.txt;md5=2085f2c228ed80422edf70e52e86c34b"
6
7PYPI_PACKAGE_EXT = "zip"
8
9SRC_URI[md5sum] = "f9c1fab00fd981be588fc32759f474e3"
10SRC_URI[sha256sum] = "dc972e06094b9af5b855b3df4a646395e43d1c9d0d39ed345b7393560d0b9173"
11
12inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb b/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb
index 35c0555..5a1cc6a 100644
--- a/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-simplegeneric_0.8.1.bb
@@ -1,12 +1,2 @@
1DESCRIPTION = "Simple generic functions" 1inherit setuptools
2HOMEPAGE = "https://pypi.python.org/pypi/simplegeneric/" 2require python-simplegeneric.inc
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.txt;md5=2085f2c228ed80422edf70e52e86c34b"
6
7PYPI_PACKAGE_EXT = "zip"
8
9SRC_URI[md5sum] = "f9c1fab00fd981be588fc32759f474e3"
10SRC_URI[sha256sum] = "dc972e06094b9af5b855b3df4a646395e43d1c9d0d39ed345b7393560d0b9173"
11
12inherit setuptools pypi
diff --git a/meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb b/meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb
new file mode 100644
index 0000000..56ad221
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-simplegeneric_0.8.1.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-simplegeneric.inc