summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
index 7f3b9e3..582f759 100644
--- a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
+++ b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
@@ -43,14 +43,14 @@ FILES:${PN}-dbg += "${base_libdir}/security/.debug"
43LDAP_DN ?= "dc=my-domain,dc=com" 43LDAP_DN ?= "dc=my-domain,dc=com"
44 44
45do_install:append() { 45do_install:append() {
46 install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd 46 install -D -m 0755 ${UNPACKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
47 47
48 sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf 48 sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
49 sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf 49 sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
50 sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf 50 sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
51 51
52 install -d ${D}${systemd_unitdir}/system 52 install -d ${D}${systemd_unitdir}/system
53 install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_unitdir}/system 53 install -m 0644 ${UNPACKDIR}/nslcd.service ${D}${systemd_unitdir}/system
54} 54}
55 55
56inherit update-rc.d systemd 56inherit update-rc.d systemd