summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch23
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb21
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch
new file mode 100644
index 0000000..712f3e8
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch
@@ -0,0 +1,23 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
new file mode 100644
index 0000000..6eb32f5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/"
3SECTION = "devel/python"
4LICENSE = "PSFv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
6
7PR = "r0"
8SRCNAME = "pycrypto"
9
10SRC_URI = "https://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/${SRCNAME}-${PV}.tar.gz \
11 file://cross-compiling.patch"
12
13SRC_URI[md5sum] = "88dad0a270d1fe83a39e0467a66a22bb"
14SRC_URI[sha256sum] = "7293c9d7e8af2e44a82f86eb9c3b058880f4bcc884bf3ad6c8a34b64986edde8"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18export BUILD_SYS
19export HOST_SYS
20
21inherit distutils