summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch63
-rw-r--r--meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb5
2 files changed, 47 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
index 6b72ef7..b2f94dd 100644
--- a/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
+++ b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
@@ -1,14 +1,37 @@
1Upstream-status: Inappropriate [embedded specific] 1From 392c4581da49f133938e70f6215bfebba28ecc56 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 4 Aug 2015 20:59:18 -0400
4Subject: [PATCH] setup: don't use pg_config
2 5
3The package uses the pg_config command to detect the libdir and includedir path. 6The package uses the pg_config command to detect the libdir and
4Commented the lines because the command is not available at buildtime and the 7includedir path. Commented the lines because the command is not
5package succesfully build without them. 8available at buildtime and the package succesfully build without them.
6 9
7Index: psycopg2-2.5/setup.py 10Signed-off-by: Mark Asselstine <bruce.ashfield@windriver.com>
8=================================================================== 11Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
9--- psycopg2-2.5.orig/setup.py 12---
10+++ psycopg2-2.5/setup.py 13 setup.cfg | 2 +-
11@@ -377,9 +377,6 @@ 14 setup.py | 5 +----
15 2 files changed, 2 insertions(+), 5 deletions(-)
16
17diff --git a/setup.cfg b/setup.cfg
18index 90a47dd..986871b 100644
19--- a/setup.cfg
20+++ b/setup.cfg
21@@ -9,7 +9,7 @@ define=
22 # build psycopg2. If pg_config is not in the path or is installed under a
23 # different name uncomment the following option and set it to the pg_config
24 # full path.
25-#pg_config=
26+pg_config="/bin/true"
27
28 # Set to 1 to use Python datetime objects for default date/time representation.
29 use_pydatetime=1
30diff --git a/setup.py b/setup.py
31index 975fe10..85502ca 100644
32--- a/setup.py
33+++ b/setup.py
34@@ -389,16 +389,13 @@ class psycopg_build_ext(build_ext):
12 self.libraries.append("pq") 35 self.libraries.append("pq")
13 36
14 try: 37 try:
@@ -18,16 +41,14 @@ Index: psycopg2-2.5/setup.py
18 try: 41 try:
19 # Here we take a conservative approach: we suppose that 42 # Here we take a conservative approach: we suppose that
20 # *at least* PostgreSQL 7.4 is available (this is the only 43 # *at least* PostgreSQL 7.4 is available (this is the only
21Index: psycopg2-2.5/setup.cfg 44 # 7.x series supported by psycopg 2)
22=================================================================== 45 pgversion = pg_config_helper.query("version").split()[1]
23--- psycopg2-2.5.orig/setup.cfg 46 except:
24+++ psycopg2-2.5/setup.cfg 47- pgversion = "7.4.0"
25@@ -11,7 +11,7 @@ 48+ pgversion = "9.4.4"
26 # build psycopg2. If pg_config is not in the path or is installed under a
27 # different name uncomment the following option and set it to the pg_config
28 # full path.
29-#pg_config=
30+pg_config="/bin/true"
31 49
32 # Set to 1 to use Python datetime objects for default date/time representation. 50 verre = re.compile(
33 use_pydatetime=1 51 r"(\d+)\.(\d+)(?:(?:\.(\d+))|(devel|(alpha|beta|rc)\d+))")
52--
532.1.4
54
diff --git a/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb b/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb
index 8882903..1d78afa 100644
--- a/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb
@@ -9,6 +9,7 @@ PR = "r0"
9SRCNAME = "psycopg2" 9SRCNAME = "psycopg2"
10 10
11SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ 11SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
12 file://remove-pg-config.patch \
12 " 13 "
13 14
14SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1" 15SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1"
@@ -17,3 +18,7 @@ SRC_URI[sha256sum] = "6acf9abbbe757ef75dc2ecd9d91ba749547941abaffbe69ff2086a9e37
17S = "${WORKDIR}/${SRCNAME}-${PV}" 18S = "${WORKDIR}/${SRCNAME}-${PV}"
18 19
19inherit distutils 20inherit distutils
21
22DEPENDS += " \
23 postgresql \
24"