summaryrefslogtreecommitdiffstats
path: root/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@eng.windriver.com>2023-10-14 23:19:43 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-10-16 18:23:53 +0000
commit28fcb27fbbab03a412f2126da3bec79acda6d9b0 (patch)
tree75be907434f91400a176d452198b0aaf23fcef9f /recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
parent69ba7c9276b3b7fa5af12b3881a3e94964545449 (diff)
downloadmeta-cloud-services-28fcb27fbbab03a412f2126da3bec79acda6d9b0.tar.gz
kirkstone[][PATCH] nss-pam-ldapd: upgrade 0.9.8 -> 0.9.12
Changelog: https://arthurdejong.org/nss-pam-ldapd/release-0-9-12 Add a patch to fix shebang to python3 for getent.py and chsh.py. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb')
-rw-r--r--recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
new file mode 100644
index 0000000..7f3b9e3
--- /dev/null
+++ b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb
@@ -0,0 +1,61 @@
1SUMMARY = "NSS and PAM module for using LDAP as a naming service"
2DESCRIPTION = "\
3 daemon for NSS and PAM lookups using LDAP \
4 This package provides a daemon for retrieving user accounts and similar \
5 system information from LDAP. It is used by the libnss-ldapd and \
6 libpam-ldapd packages but is not very useful by itself. \
7 "
8
9HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
10
11LICENSE = "LGPL-2.1-only"
12LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
13SECTION = "base"
14
15FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
16
17SRC_URI = "\
18 http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
19 file://0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch \
20 file://nslcd.init \
21 file://nslcd.service \
22 "
23
24inherit autotools features_check
25REQUIRED_DISTRO_FEATURES = "pam"
26
27SRC_URI[md5sum] = "cc30ee0ab91d6c94b7a343ae09b5dc69"
28SRC_URI[sha256sum] = "c6d661e74693cbf531a790631ca93b73f291fb23cc39465b09deb8da2bfb0e14"
29
30DEPENDS += "libpam openldap krb5"
31
32EXTRA_OECONF = "\
33 --disable-pynslcd \
34 --libdir=${base_libdir} \
35 --with-pam-seclib-dir=${base_libdir}/security \
36 "
37
38CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
39
40FILES:${PN} += "${base_libdir}/security ${datadir}"
41FILES:${PN}-dbg += "${base_libdir}/security/.debug"
42
43LDAP_DN ?= "dc=my-domain,dc=com"
44
45do_install:append() {
46 install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
47
48 sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
49 sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
50 sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
51
52 install -d ${D}${systemd_unitdir}/system
53 install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_unitdir}/system
54}
55
56inherit update-rc.d systemd
57
58INITSCRIPT_NAME = "nslcd"
59INITSCRIPT_PARAMS = "defaults"
60
61SYSTEMD_SERVICE:${PN} = "nslcd.service"