summaryrefslogtreecommitdiffstats
path: root/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@eng.windriver.com>2023-10-14 23:19:43 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-10-16 18:23:53 +0000
commit28fcb27fbbab03a412f2126da3bec79acda6d9b0 (patch)
tree75be907434f91400a176d452198b0aaf23fcef9f /recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
parent69ba7c9276b3b7fa5af12b3881a3e94964545449 (diff)
downloadmeta-cloud-services-28fcb27fbbab03a412f2126da3bec79acda6d9b0.tar.gz
kirkstone[][PATCH] nss-pam-ldapd: upgrade 0.9.8 -> 0.9.12
Changelog: https://arthurdejong.org/nss-pam-ldapd/release-0-9-12 Add a patch to fix shebang to python3 for getent.py and chsh.py. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch')
-rw-r--r--recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
new file mode 100644
index 0000000..86e9f7b
--- /dev/null
+++ b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch
@@ -0,0 +1,34 @@
1From fb9c5b955da462695e0a662aebfa13493eaf3978 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Fri, 13 Oct 2023 22:28:25 +0800
4Subject: [PATCH] utils/Makefile.am: fix shebang for chsh.py and getent.py
5
6Update shebang to python3 for chsh.py and getent.py to fix QA issue:
7
8WARNING: nss-pam-ldapd-0.9.12-r0 do_package_qa: QA Issue: File
9/usr/share/nslcd-utils/chsh.py in package nss-pam-ldapd contains
10reference to TMPDIR
11File /usr/share/nslcd-utils/getent.py in package nss-pam-ldapd contains
12reference to TMPDIR [buildpaths]
13
14Upstream-Status: Inappropriate [embedded specific]
15
16Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
17---
18 utils/Makefile.am | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/utils/Makefile.am b/utils/Makefile.am
22index a6bccd3..22a50d8 100644
23--- a/utils/Makefile.am
24+++ b/utils/Makefile.am
25@@ -39,5 +39,5 @@ install-data-hook:
26 set -ex; for cmd in getent chsh ; do \
27 [ -L $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ] || $(LN_S) $(utilsdir)/$$cmd.py $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ; \
28 chmod a+rx $(DESTDIR)$(utilsdir)/$$cmd.py ; \
29- sed -i -e '1 s|^#!.*|#! $(PYTHON)|;1 s|^#! \([^/].*\)|#! /usr/bin/env \1|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \
30+ sed -i -e '1 s|/usr/bin/env python|/usr/bin/env python3|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \
31 done
32--
332.25.1
34