summaryrefslogtreecommitdiffstats
path: root/recipes-support/hiera
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-08-19 22:56:11 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-08-20 13:38:48 -0400
commit1aa30310259027ebb87ee95ef914ca3de55d6a09 (patch)
tree72a940aacd777a4512771abddcd30637c29b57b7 /recipes-support/hiera
parentbd7a3f804950ae454d025aa8773789441a63820c (diff)
downloadmeta-cloud-services-1aa30310259027ebb87ee95ef914ca3de55d6a09.tar.gz
puppet: move to base layer
Puppet can be used by many 'cloud services', it is not openstack specific, so moving puppet and puppet related recipes to the meta-cloud-services base layer. This allows either internal sub-layers found in meta-cloud-services or external layers to include meta-cloud-services without being burdened by bbappends and configs found in meta-openstack. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-support/hiera')
-rw-r--r--recipes-support/hiera/hiera/add_hiera_gemspec.patch23
-rw-r--r--recipes-support/hiera/hiera_1.3.4.bb20
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-support/hiera/hiera/add_hiera_gemspec.patch b/recipes-support/hiera/hiera/add_hiera_gemspec.patch
new file mode 100644
index 0000000..7e302cf
--- /dev/null
+++ b/recipes-support/hiera/hiera/add_hiera_gemspec.patch
@@ -0,0 +1,23 @@
1diff -urN hiera-1.3.4_ori/hiera.gemspec hiera-1.3.4/hiera.gemspec
2--- hiera-1.3.4_ori/hiera.gemspec 1970-01-01 08:00:00.000000000 +0800
3+++ hiera-1.3.4/hiera.gemspec 2014-11-12 14:30:07.000000000 +0800
4@@ -0,0 +1,19 @@
5+$:.unshift(File.dirname(__FILE__) + '/lib')
6+require 'hiera/version'
7+
8+Gem::Specification.new do |s|
9+ s.name = 'hiera'
10+ s.version = Hiera::VERSION
11+ s.platform = Gem::Platform::RUBY
12+ s.summary = 'A simple pluggable Hierarchical Database.'
13+ s.description = s.summary
14+ s.author = 'Yang Haibo'
15+ s.email = 'b40869@freescale.com'
16+ s.homepage = 'https://projects.puppetlabs.com/projects/hiera'
17+ s.license = 'Apache 2.0'
18+
19+ s.bindir = 'bin'
20+ s.executables = ['hiera']
21+ s.require_path = 'lib'
22+ s.files = %w(LICENSE README.md Rakefile) + Dir.glob('{lib,spec}/**/*')
23+end
diff --git a/recipes-support/hiera/hiera_1.3.4.bb b/recipes-support/hiera/hiera_1.3.4.bb
new file mode 100644
index 0000000..eb633ff
--- /dev/null
+++ b/recipes-support/hiera/hiera_1.3.4.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A simple pluggable Hierarchical Database"
2HOMEPAGE = "https://projects.puppetlabs.com/projects/hiera"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8ac92c91fbec097f798223679c1a7491"
5
6SRC_URI = " \
7 https://downloads.puppetlabs.com/hiera/hiera-${PV}.tar.gz \
8 file://add_hiera_gemspec.patch \
9"
10SRC_URI[md5sum] = "6abccc518edb55291a63129ef30888cd"
11SRC_URI[sha256sum] = "d3ecbfedc7d8493fd00c7dd624efbb225705d289442fe7706cb81a3a7230e70e"
12
13
14inherit ruby
15
16DEPENDS += " \
17 ruby \
18"
19
20RUBY_INSTALL_GEMS = "hiera-${PV}.gem"