summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-07-31 23:31:13 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-07-31 23:49:54 -0400
commit0cffcd09a44b2a58452a5bb13714bfc47d6546bf (patch)
treeb91584b573ce42431a35a9b8f064d8be57974e1e /recipes-extended
parente887a996155f8b9f22d6aca0e31b5fbccd82751e (diff)
downloadmeta-cloud-services-0cffcd09a44b2a58452a5bb13714bfc47d6546bf.tar.gz
global: overrides conversion
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/glusterfs/glusterfs.inc42
-rw-r--r--recipes-extended/librdmacm/librdmacm_1.1.0.bb16
2 files changed, 29 insertions, 29 deletions
diff --git a/recipes-extended/glusterfs/glusterfs.inc b/recipes-extended/glusterfs/glusterfs.inc
index 81ea65e..646b521 100644
--- a/recipes-extended/glusterfs/glusterfs.inc
+++ b/recipes-extended/glusterfs/glusterfs.inc
@@ -52,8 +52,8 @@ EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \
52 " 52 "
53 53
54PACKAGECONFIG ??= "georeplication libibverbs" 54PACKAGECONFIG ??= "georeplication libibverbs"
55PACKAGECONFIG_remove_mipsarch = "libibverbs" 55PACKAGECONFIG:remove:mipsarch = "libibverbs"
56PACKAGECONFIG_remove_arm = "libibverbs" 56PACKAGECONFIG:remove:arm = "libibverbs"
57 57
58PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,," 58PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
59PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync" 59PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync"
@@ -61,7 +61,7 @@ PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibver
61PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,," 61PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,,"
62PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind," 62PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
63 63
64do_install_append() { 64do_install:append() {
65 install -d ${D}${sysconfdir}/init.d 65 install -d ${D}${sysconfdir}/init.d
66 install -m 0755 ${WORKDIR}/glusterd.init \ 66 install -m 0755 ${WORKDIR}/glusterd.init \
67 ${D}${sysconfdir}/init.d/glusterd 67 ${D}${sysconfdir}/init.d/glusterd
@@ -108,29 +108,29 @@ INITSCRIPT_NAME = "glusterd"
108INITSCRIPT_PARAMS = "start 20 5 3 2 . stop 80 0 1 6 ." 108INITSCRIPT_PARAMS = "start 20 5 3 2 . stop 80 0 1 6 ."
109 109
110SYSTEMD_PACKAGES = "glusterfs-server" 110SYSTEMD_PACKAGES = "glusterfs-server"
111SYSTEMD_SERVICE_${PN} = "glusterd.service" 111SYSTEMD_SERVICE:${PN} = "glusterd.service"
112SYSTEMD_AUTO_ENABLE = "disable" 112SYSTEMD_AUTO_ENABLE = "disable"
113 113
114# Allow plug-in symlinks. 114# Allow plug-in symlinks.
115INSANE_SKIP_${PN} += "dev-so" 115INSANE_SKIP:${PN} += "dev-so"
116INSANE_SKIP_${PN}-rdma += "dev-so" 116INSANE_SKIP:${PN}-rdma += "dev-so"
117INSANE_SKIP_${PN}-fuse += "dev-so" 117INSANE_SKIP:${PN}-fuse += "dev-so"
118INSANE_SKIP_${PN}-server += "dev-so" 118INSANE_SKIP:${PN}-server += "dev-so"
119 119
120PACKAGES += "${PN}-rdma ${PN}-geo-replication ${PN}-fuse ${PN}-server \ 120PACKAGES += "${PN}-rdma ${PN}-geo-replication ${PN}-fuse ${PN}-server \
121 ${PN}-api ${PN}-ocf" 121 ${PN}-api ${PN}-ocf"
122 122
123RDEPENDS_${PN} += "python3-core python3-json python3-ctypes bash" 123RDEPENDS:${PN} += "python3-core python3-json python3-ctypes bash"
124RDEPENDS_${PN}-ocf += "bash" 124RDEPENDS:${PN}-ocf += "bash"
125RDEPENDS_${PN}-server += "bash" 125RDEPENDS:${PN}-server += "bash"
126RDEPENDS_${PN}-geo-replication += "python3-core bash" 126RDEPENDS:${PN}-geo-replication += "python3-core bash"
127 127
128FILES_${PN}-dbg += "${libdir}/glusterfs/${PV}/*/.debug \ 128FILES:${PN}-dbg += "${libdir}/glusterfs/${PV}/*/.debug \
129 ${libdir}/glusterfs/${PV}/*/*/.debug \ 129 ${libdir}/glusterfs/${PV}/*/*/.debug \
130 ${libdir}/glusterfs/${PV}/*/*/*/.debug \ 130 ${libdir}/glusterfs/${PV}/*/*/*/.debug \
131 ${libexecdir}/glusterfs/.debug" 131 ${libexecdir}/glusterfs/.debug"
132 132
133FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \ 133FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
134 ${libdir}/glusterfs/${PV}/rpc-transport/socket* \ 134 ${libdir}/glusterfs/${PV}/rpc-transport/socket* \
135 ${libdir}/glusterfs/${PV}/xlator/cluster \ 135 ${libdir}/glusterfs/${PV}/xlator/cluster \
136 ${libdir}/glusterfs/${PV}/xlator/debug \ 136 ${libdir}/glusterfs/${PV}/xlator/debug \
@@ -182,20 +182,20 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
182 ${datadir}/glusterfs/* \ 182 ${datadir}/glusterfs/* \
183 " 183 "
184 184
185FILES_${PN}-rdma = "${libdir}/glusterfs/${PV}/rpc-transport/rdma*" 185FILES:${PN}-rdma = "${libdir}/glusterfs/${PV}/rpc-transport/rdma*"
186 186
187FILES_${PN}-geo-replication = "${libexecdir}/glusterfs/gsyncd \ 187FILES:${PN}-geo-replication = "${libexecdir}/glusterfs/gsyncd \
188 ${libexecdir}/glusterfs/python/syncdaemon \ 188 ${libexecdir}/glusterfs/python/syncdaemon \
189 ${libexecdir}/glusterfs/peer_georep-sshkey.py \ 189 ${libexecdir}/glusterfs/peer_georep-sshkey.py \
190 ${libexecdir}/glusterfs/set_geo_rep_pem_keys.sh \ 190 ${libexecdir}/glusterfs/set_geo_rep_pem_keys.sh \
191 ${sbindir}/gluster-georep-sshkey" 191 ${sbindir}/gluster-georep-sshkey"
192 192
193FILES_${PN}-fuse = "${bindir}/fusermount-glusterfs \ 193FILES:${PN}-fuse = "${bindir}/fusermount-glusterfs \
194 ${libdir}/glusterfs/${PV}/xlator/mount \ 194 ${libdir}/glusterfs/${PV}/xlator/mount \
195 ${sbindir}/mount.glusterfs \ 195 ${sbindir}/mount.glusterfs \
196 ${base_sbindir}/mount.glusterfs" 196 ${base_sbindir}/mount.glusterfs"
197 197
198FILES_${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \ 198FILES:${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
199 ${libdir}/glusterfs/${PV}/xlator/nfs \ 199 ${libdir}/glusterfs/${PV}/xlator/nfs \
200 ${libdir}/glusterfs/${PV}/xlator/protocol/server* \ 200 ${libdir}/glusterfs/${PV}/xlator/protocol/server* \
201 ${libdir}/glusterfs/${PV}/xlator/storage \ 201 ${libdir}/glusterfs/${PV}/xlator/storage \
@@ -208,11 +208,11 @@ FILES_${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
208 ${systemd_system_unitdir}" 208 ${systemd_system_unitdir}"
209 209
210# Note: Debian package renaming produces libgfapi[0-9]+-*.*.rpm. 210# Note: Debian package renaming produces libgfapi[0-9]+-*.*.rpm.
211FILES_${PN}-api = "${libdir}/libgfapi.so.*" 211FILES:${PN}-api = "${libdir}/libgfapi.so.*"
212 212
213FILES_${PN}-ocf = "${prefix}/lib/ocf" 213FILES:${PN}-ocf = "${prefix}/lib/ocf"
214 214
215pkg_postinst_${PN}() { 215pkg_postinst:${PN}() {
216 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ]; then 216 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ]; then
217 /etc/init.d/populate-volatile.sh update 217 /etc/init.d/populate-volatile.sh update
218 fi 218 fi
diff --git a/recipes-extended/librdmacm/librdmacm_1.1.0.bb b/recipes-extended/librdmacm/librdmacm_1.1.0.bb
index edf92f0..2e18b0a 100644
--- a/recipes-extended/librdmacm/librdmacm_1.1.0.bb
+++ b/recipes-extended/librdmacm/librdmacm_1.1.0.bb
@@ -24,21 +24,21 @@ SRC_URI[sha256sum] = "8f10848d4810585d6d70b443abc876c1db8df5e9b8b07e095c7e6eaf4a
24inherit autotools 24inherit autotools
25 25
26# Allow plug-in symlinks. 26# Allow plug-in symlinks.
27INSANE_SKIP_${PN} += "dev-so" 27INSANE_SKIP:${PN} += "dev-so"
28 28
29PACKAGES += "${PN}-utils" 29PACKAGES += "${PN}-utils"
30FILES_${PN} = "${libdir}/*.so.* ${libdir}/rsocket/*.so*" 30FILES:${PN} = "${libdir}/*.so.* ${libdir}/rsocket/*.so*"
31FILES_${PN}-utils = "${bindir}" 31FILES:${PN}-utils = "${bindir}"
32FILES_${PN}-staticdev += "${libdir}/rsocket/librspreload.a" 32FILES:${PN}-staticdev += "${libdir}/rsocket/librspreload.a"
33FILES_${PN}-dbg += "${libdir}/rsocket/.debug" 33FILES:${PN}-dbg += "${libdir}/rsocket/.debug"
34 34
35PACKAGECONFIG ??= "" 35PACKAGECONFIG ??= ""
36PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind," 36PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind,"
37 37
38do_install_append() { 38do_install:append() {
39 rm -f ${D}${libdir}/librdmacm.la 39 rm -f ${D}${libdir}/librdmacm.la
40 rm -f ${D}${libdir}/rsocket/librspreload.la 40 rm -f ${D}${libdir}/rsocket/librspreload.la
41} 41}
42 42
43COMPATIBLE_HOST_mipsarch = "none" 43COMPATIBLE_HOST:mipsarch = "none"
44COMPATIBLE_HOST_arm = "none" 44COMPATIBLE_HOST:arm = "none"